Question Can an accidentally Pulled out CPU ruin a motherboard despite no pin damage?

Apr 25, 2021
2
0
10
0
TLDR: I switched out a motherboard on a build from November only to find the brand new motherboard won't POST. When I went back my Original Motherboard that too now won't post. The only thing that I changed was the motherboard, everything else remained the same. Note: CPU might have fried during this for reasons explained below.

Background:
In November I ordered parts to build a Ryzen 9 editing rig and for the most part was pleased but had issues along the way that made me think something was off, specifically the motherboard. The issue specifically was I would Alt-Tab in and out of Avid MediaComposer to other programs and when I'd get back into Avid, it would freeze for about 10 to 15 seconds. This would be acceptable if I wasn't needing to go back and forth between programs so much.

For those of you not familiar with Avid, they don't technically support AMD builds because they don't test them, though I think they're coming around to testing more and more of them. I took a calculated chance with this build based on success that other people had with using Avid and AMD. I was shocked that everything but Alt-Tabbing worked in Avid on my AMD but equally disappointed in the fact of how much time lost freezes from such a problem can cause.

How I diagnosed:
After performing multiple RAM tests to make sure it wasn't a RAM issue, I upgraded the BIOS, and did a fresh install of windows. This worked very briefly and improved some issues but the problem came back in no time. My next thought was maybe this particular MOBO was problematic for what I was trying to do so I ordered a different one that other users on Avid Forums mentioned using on their AMD builds.

So the new MOBO arrives and I go to take my CPU cooler off my Ryzen, and it being the stock thermal paste, rips the whole CPU out with the cooler. According to things I've read online, this is not only common with Ryzens, but as long as the pins weren't damaged everything should be fine. After a thorough inspection of both the old motherboard and CPU pins I see no damage and proceed. I put the cpu and cooler into the Aorus x570 wifi , install RAM, ad Power connections and....nothing. The RAM lights up but the board won't POST and the fans won't spin when I turn it on. After moving some things around and trying and trying I decide this board is messed up from the factory so I take everything apart.

I go back to my existing motherboard, put everything together, and nothing. not even lights. Since it's a computer issue I wait a few days to try again, but again nothing.

Is it obvious my CPU was broken from removing the cooler and is it further possible it screwed up both Motherboards? Also, has anyone had positive experiences with RMAs for AMD and ASUS, respectively? Would it be worth trying a third motherboard in the meantime to see if that works or am I wasting my time and motherboards at this point?


I don't have a ton of time to wait for this stuff to be fixed, as I use this for work and am now relying on a 7 year old back up.

Thank you in advance.




Parts

Ryzen 9 3900 X
ASUS PRIME X570-PRO
64GB GSkill TridentZ
Nvidia RTX2070-SUPER
Corsair M.2 1TB Boot Drive - WIN 10 Pro
Corsair RM750 PSU

New Motherboard: Aorus x570 wifi
 

Karadjgne

Titan
Ambassador
I go back to my existing motherboard, put everything together, and nothing. not even lights.
Cpu isn't the first thing on the list, motherboard is. When you push the button, the psu sends power to bios, which pulls settings from cmos, then knocks on the cpus door.

If you aren't seeing a boot led, power leds on gpu or other such, then the obvious conclusion is the psu isn't sending power. The psu has a 5vSB, that's a Standby voltage rail and when the pc is off, that stays on. You should be seeing lights on the board somewhere, IF both the power plugs are in and the switch in the back of the psu is set to 'I' and plugged into the wall in an active outlet.
 
Apr 25, 2021
2
0
10
0
Hey,

Yeah I didn't think so but figured anything was possible with a computer!

So the new Mobo had power to the RGB on the RAM but nothing beyond that and no power at all to the "old" MOBO. I thought the PSU might have an issue but I've been able to use it now with an old motherboard but it's only the one 8 pin CPU connector, not the 8+4, like the with new motherboards.

I guess the next thing is getting another PSU to test the old MOBO again as I've already sent back the new one.
 

ASK THE COMMUNITY

TRENDING THREADS