Question Can anyone help plz?

Nov 19, 2019
1
0
10
0
So im trying to upgrade my cpu from a Ryzen 3 to a Ryzen 5. However, after installing the new cpu nothing shows on the display. The computer boots up like the fans and all that but doesnt display anything. I have put my Ryzen 3 back into the computer and it starts right up like normal.

Does anyone know what is happening?

My best guess would be updating BIOS but not sure. I would have thought it would be a simple replacement.

What i have now is -
Processor (CPU) - AMD Ryzen 3 1300X Quad Core CPU (3.5GHz-3.7GHz/10MB CACHE/AM4)
Motherboard - ASUS®️ PRIME X370-PRO (DDR4, 6Gb/s, CrossFireX/SLI)

New cpu - AMD Ryzen 5 2600X Processor

If you need any more information let me know.
 
So im trying to upgrade my cpu from a Ryzen 3 to a Ryzen 5. However, after installing the new cpu nothing shows on the display. The computer boots up like the fans and all that but doesnt display anything. I have put my Ryzen 3 back into the computer and it starts right up like normal.

Does anyone know what is happening?

My best guess would be updating BIOS but not sure. I would have thought it would be a simple replacement.

What i have now is -
Processor (CPU) - AMD Ryzen 3 1300X Quad Core CPU (3.5GHz-3.7GHz/10MB CACHE/AM4)
Motherboard - ASUS®️ PRIME X370-PRO (DDR4, 6Gb/s, CrossFireX/SLI)

New cpu - AMD Ryzen 5 2600X Processor

If you need any more information let me know.
You need to update to BIOS https://www.asus.com/us/Motherboards/PRIME-X370-PRO/HelpDesk_Download/ while still having old CPU installed.
 
Reactions: SomethingLikeThat

ASK THE COMMUNITY

TRENDING THREADS