[SOLVED] Can I assume the CPU I just bought on ebay is dead?

Feb 16, 2019
2
1
15
0
Hi,

I bought a second hand i5 4690K from eBay to replace my i3 4130 processor which is working fine because I wanted a system upgrade. I plugged it into my H81M-HDS Asrock Motherboard but the computer doesn’t even POST. As soon as I power it, it emits 4 short and fast beeps and keeps doing this in a loop. I checked that on Asrock and it means “System Timer Failure”.

I had no GPU connected during the tests, my PSU is a Corsair CX550M. Things I have tried:
  • Checked that my motherboard is compatible with the CPU.
  • I have two RAM cards and 2 channels on my motherboard. I have tried plugging them in every combination possible (1 RAM stick inserted, 2 RAM sticks inserted, changed the position of the RAM sticks…).
  • Removed battery to reset CMOS.
  • I already had the most up-to-date BIOS, but I updated it to the latest beta version (2.30A).
  • Downgraded BIOS to a previous version that was listed on the Asrock web to be the fist to accept this CPU
  • Checked on Windows that the RAM memory is working properly.
  • Tried different CPU fans.
  • Replaced thermal paste.
The thing is that as soon as I plugged in the i3 4130 back again, everything works perfectly (I’m using it to write this :). Do you think it is safe to assume this i5 CPU is faulty? Do I need to try something more?

Thanks in advance.
 

ASK THE COMMUNITY