[SOLVED] Can I use 15A 125v EVGA PSU power cord on 240v

Dec 23, 2021
2
0
10
0
Hello Everyone,

I have bought EVGA SUPERNOVA P2 1200W ATX PSU from USA. Power cord for this PSU says 15A 125V. But I live in a country where we use 240V.
But on the power cord cable it says 300V. So it can handle max of 300V? Can I use this power cord with 240V?

Other option that I have is 10A 240V power cord as replacement. I won't be crossing exceeding 900W on this PSU so I assume 10A 240V power cord should be sufficient?

Thanks.
 

kanewolf

Titan
Moderator
Have an extension cord which will fit the north American plug type.

Thanks
Ideally, you want the wire gauge in the extension cord to be larger (lower number) than any cord plugged into it. That way you don't get a voltage drop from the extension cord. This is probably a short cord, and the amperage won't be very high with a PC so it shouldn't be a problem. But it is something to keep in mind.
 

kanewolf

Titan
Moderator
Hello Everyone,

I have bought EVGA SUPERNOVA P2 1200W ATX PSU from USA. Power cord for this PSU says 15A 125V. But I live in a country where we use 240V.
But on the power cord cable it says 300V. So it can handle max of 300V? Can I use this power cord with 240V?

Other option that I have is 10A 240V power cord as replacement. I won't be crossing exceeding 900W on this PSU so I assume 10A 240V power cord should be sufficient?

Thanks.
You can use the cord. Are you going to use an adapter for the USA mains plug ?
 
Reactions: Maheshrpp

kanewolf

Titan
Moderator
Have an extension cord which will fit the north American plug type.

Thanks
Ideally, you want the wire gauge in the extension cord to be larger (lower number) than any cord plugged into it. That way you don't get a voltage drop from the extension cord. This is probably a short cord, and the amperage won't be very high with a PC so it shouldn't be a problem. But it is something to keep in mind.
 

Pextaxmx

Prominent
Jun 15, 2020
303
33
740
6
Higher voltage for same power is easier on cords...

300V limit is insulation spec, not the conductor spec. Your cord has insulation that does not cause arcs between conductors up to 300V.
 

ASK THE COMMUNITY