Can not switch nVidia Physix to GPU

Shaba062

Reputable
Dec 20, 2015
6
0
4,510
0
Hi guys,

I have this problem and I searched on it but didn't find solution. I have noticed that my CPU is used 90-100% in almost every game, but my GPU is used 50%. I tried to change the setting to lower res, lower detail but FPS stays the same. Then I realized that Physix are set on CPU so I switched it on GPU but it still stayed on CPU and doesn't want to change.

My setup is:

i5-4460 @ 3.20GHz
GTX 1050Ti
8 GB DDR3 (2x4GB)
Windows 7 Professional 64-bit SP1
 

koson123

Proper
Oct 12, 2018
67
2
165
9
dont bother with it i have seen sugestions to switch it to cpu anyways try setting it to auto and use geforce experience to download the latest drivers but dont spend to much time on this

Side note: 1050 ti does not have much extra performance anyways this may be for the best
 

Karadjgne

Titan
Herald
No, you have a 4core/4thread cpu. Many games are making the move to optimization for 8 threads or more, they'll work on a 4c/4t, but the cpus are so packed that it's not uncommon to see upto 100% usage.

Resolution and most game details are the gpu issue, got almost nothing to do with the cpu at all. There are some, like physX, grass details, viewing distance that have bearing on the cpu. They'll be found for global settings in nvidia control panel, or per game in GeForce Experience or game graphics settings.
 

Shaba062

Reputable
Dec 20, 2015
6
0
4,510
0


Well for example in Fortnite. My graphic settings are:

Res: 1920x1080p
View distance: Far
AA: Medium
Textures: High
Rest is low.

I lock my fps to 60 cause of CPU usage, but even then I get drops to 20-30 FPS in closeup fights. I don't know if the problem is cause I run 2 monitors ?

I just played game of Fortnite on these settings just turned down view distance to low and lock at 60FPS. Got max load of CPU average 95% on all 4 cores, and max load of GPU 40% :S
 

Karadjgne

Titan
Herald
I run 2x monitors, unless you have them extended in game to cover both at the same time, monitors use so little gpu power by themselves that you may as well count them as just 1.

3770k with gtx970 on fortnight, dual monitors 1080p, ultra settings, no AA, 60+ fps.

You've got all the gpu settings on low, that's going to make things harder on the cpu. Should have as much gpu as possible, give the cpu a break.
 

ASK THE COMMUNITY