Question Can not use full memory - system reserved


Jun 1, 2010
Can not use full memory

Screenshot - Imgur

Hi, I hope you can help

My eldest son and I built a PC for my youngest in December 2021. When we did it was only showing as running 8GB of the 16GB installed (Crucial Ballistix RGB 16GB (2x 8GB) 3200MHz DDR4 RAM). They were bought as a pair. We did try to fix it at the time but came up with no solutions and assumed either a) it was just a display issue or b) he wouldn’t even noticed.

To skip the below, it’s possibly the BIOS Update but before I do that I would like to rule out the graphics card (Nvidia P620) which I think is the culprit.

Fast forward to 2023 and he can’t play the current EA24 without issues. The issue is the memory and:
  • Windows is showing 16GB installed
  • BIOS is showing 16GB installed
  • Only 8GB used
The motherboard (Gigabyte A320M-S2H) only has two memory slots so I assume it is not a channel issue. What I did find out is it’s 8.1GB “hardware reserved” (see screenshot) while my other son and I only have 0.1GB reserved

What I have tried before realising it’s a reserved issue
  • Running with either slot with just 8B
  • Both sticks separately
  • Swapping the 2*8GB
What I have tried since:
  • (except Update BIOS)
  • Change maximum memory in System configuration
  • Changed virtual memory settings
  • Updated windows
  • Restored BIOS to default (we had played with settings in a failed attempt to install Windows 11)
  • Updated drivers
  • Swapped the memory sticks with the working Corsair Vengeance LPX 16GB (2x 8GB) 3200MHz DDR4 from my system.
What I haven’t done:
  • updated BIOS
  • solved the issue


It may be helpful for you to list specific hardware list including PSU and BIOS revision information.

Just quickly to say that (without knowing further) the 3xx chipsets for Ryzen and particularly 1st gen compatibility for RAM was a known quantity early on. Check your motherboard website and closely read the BIOS notes for compatibility for your specific CPU. Install the BIOS updates each and every one in order unless the notes absolutely specify differently (in those notes). If you have a 1st gen CPU going past a certain BIOS (if supported by the mobo) can eliminate support, so please pay close attention and ask if you have further questions.

I had two B350 and an X370 (Taichi) that were super picky about RAM. The B series I just picked some stuff up off the QVL. Since they don't often update that, I would not expect you would find what is tested at this late point.