Build Advice Can someone tell me how swapping gpus killed my computer

Aug 31, 2022
7
0
10
0
My specs were: R5 3600x, b550 aorus pro ac, 2x8gb gskill ripjaws 5, msi 2060 ventus oc, cx650 80+ bronze. When i swapped out my 2060 for a evga 3070 ftw3 my computer wouldn’t power on. No fans nothing, even when i switched back to my 2060. I switched my mobo for a msi b550m pro vdh wifi. Then it started powering on but it reboots randomly. I got into windows a few times but it would reboot. Then i could only get to the bios and it would reboot. Now I can’t even get to the bios. I bought an rm850 80+ gold and it does the same thing with both psu. Plz help im at my wits end and wishing i never got a 3070
Ive already tried booting with each individual stick of ram.
Ive already updated the bios.
Video of what it's doing:
 
Maybe there something wrong with your new motherboard, Have you tried using your old motherboard and test to see if it restarts!

edited try placing your ram on 2 and 4th slot and not 1 or 3 because i had fault on my new motherboard would not overclock and ornage light kept solid until restarted my computer turned out place ram in wrong socket
 
Aug 31, 2022
7
0
10
0
Maybe there something wrong with your new motherboard, Have you tried using your old motherboard and test to see if it restarts!

edited try placing your ram on 2 and 4th slot and not 1 or 3 because i had fault on my new motherboard would not overclock and ornage light kept solid until restarted my computer turned out place ram in wrong socket
its in 2 and 4 slot
 

DavidM012

Honorable
Feb 4, 2016
883
130
11,240
34
EZ Debug LED These LEDs indicate the debug status of the motherboard.

CPU - indicates CPU is not detected or fail.
DRAM - indicates DRAM is not detected or fail.
VGA - indicates GPU/ PCIE/ M.2 device is not detected or fail.
BOOT - indicates the booting device is not detected or fail.

The common factor between the 2 mobos not booting is the gpu.

The manual says it's VGA and boot device is not detected or fail. So the not booting led goes off after the no vga led but they don't boot with no vga anyway. It's all happening on the pci express bus.

The Gpu is most probably just a doa.

So remove the 3070 just put your 2060 in the new mobo see if it works theoretically the way the evidence leans says it will then it must be the 3070 was a doa.

You switched the psu for a new one that's reliable.

So the whatever's wrong with the 3070 might be rekking components if it's some sort of power fault.

Then question the source of the 3070.
 
Last edited:
Aug 31, 2022
7
0
10
0
EZ Debug LED These LEDs indicate the debug status of the motherboard.

CPU - indicates CPU is not detected or fail.
DRAM - indicates DRAM is not detected or fail.
VGA - indicates GPU/ PCIE/ M.2 device is not detected or fail.
BOOT - indicates the booting device is not detected or fail.

The common factor between the 2 mobos not booting is the gpu.

The manual says it's VGA and boot device is not detected or fail. So the not booting led goes off after the no vga led but they don't boot with no vga anyway. It's all happening on the pci express bus.

The Gpu is most probably just a doa.

So remove the 3070 just put your 2060 in the new mobo see if it works theoretically the way the evidence leans says it will then it must be the 3070 was a doa.

You switched the psu for a new one that's reliable.

So the whatever's wrong with the 3070 might be rekking components if it's some sort of power fault.

Then question the source of the 3070.
I had the 3070 sold and shipped from amazon, is it really possible that the gpu rekt my components?
 

ASK THE COMMUNITY

TRENDING THREADS