[SOLVED] Cannot access newly installed Patriot SSD ?

Tac 25

Notable
Jul 25, 2021
808
189
1,090
8
Hi, have installed a second SSD to my budget gaming pc. It's a Patriot P210 512 GB.

it's detected just fine by HwMonitor and Device manager.


however, it's not showing up in Devices and Drives, so it cannot be accessed.


any suggestions on how to fix this issue? thanks.

oh, btw.. the TS48 is my Transcend SSD, it's the boot drive. Nothing wrong with it. :)
 

dwd999

Honorable
Hi, have installed a second SSD to my budget gaming pc. It's a Patriot P210 512 GB.

it's detected just fine by HwMonitor and Device manager.


however, it's not showing up in Devices and Drives, so it cannot be accessed.


any suggestions on how to fix this issue? thanks.

oh, btw.. the TS48 is my Transcend SSD, it's the boot drive. Nothing wrong with it. :)
Try thinking outside of the windows box. Download a disk partitioning tool like Gparted, mount it on a usb and boot from that. See if its recognized and if it has a GPT identifier. You can also use Gparted to create a partition and format the drive. If Gparted or a similar tool doesn't work the drive may simply be defective and should be returned.
 
Reactions: Tac 25

Tac 25

Notable
Jul 25, 2021
808
189
1,090
8
@Nine Layer Nige

yeah, I double checked. It's connected SATA and power.

also visible in disk management. It's "Disk 1", the unallocated.


also, when I check properties in device manager. Windows says the ssd is working properly.



should I try updating the driver?
 

ASK THE COMMUNITY

TRENDING THREADS