Question Cannot boot desktop & desktop icons disappear while using new Displayport cable (VESA Certified) ?

Dec 31, 2020
7
0
10
0
Hi, I bought Dell XPS 8940 desktop plus Dell 4K monitor S2721QS ( https://www.dell.com/en-ca/shop/accessories/apd/210-AXLG) this month and I upgraded graphic card to NVIDIA(R) GeForce(R) GTX 1650 SUPER 4GB GDDR6. I use one monitor only and everything is pretty default setting. This graphic card has displayport 1.4 and the Dell 4K monitor S2721QS has displayport 1.2 .

But this XPS only includes HDMI cable, displayport cable is not included so I bought a third party displayport cable which is VESA Certified at https://www.amazon.ca/Cable-Matters-Certified-Braided-DisplayPort/dp/B08637G66P/?th=1 and after I connected this displayport cable, disconnected the Dell HDMI cable and chose DP input instead of HDMI input for my monitor (onscreen selection), the screen says no DP connection or cable detected and I could not boot my computer. I connected HDMI cable back and now I have both DP cable and HDMI cable connected and if I choose DP imput for monitor, I still cannot boot computer even though this time it detects the DP connection. So with both cables still connected to the computer and monitor, I chose HDMI connection on monitor (onscreen selection), I could boot the computer now. I switched back to DP connection for monitor (onscreen selection) and I could see the desktop background and taskbar items on the bottom but the desktop icons disappear. The only way I can see the the desktop icons is to use HDMI cable instead of DP connection. I searched online for this issue and some people mentioned a displayport cable with live 20th pin can damage hardware including but not limited to GPU, I am very worried my hardware or GPU has been damaged. May I ask how can I confirm none of the hardware nor GPU has been damaged? I am now using hdmi cable only and I no longer want to use any displayport cable because this is freaking me out. I can see the normal screen. Although the displayport cable that I ordered mentions it's VESA Certified on the website but what if the one that they shipped to me is not VESA verified? But this displayport cable has very high rating on Amazon so I dunno if the issues (cannot boot computer issue and the desktop icons disappear) are due to the displayport cable or my monitor setting or graphic card. I plan to return the displayport cable, my only concern is I am worrying that my hardware or GPU has already been damaged. Please help.


XPS 8940 specs:

Windows 10 Home (64bit)
360W Night Sky Bezel Chassis not including optical drive
10th Gen Intel(R) Core(TM) i5-10400 processor(6-Core, 12M Cache, 2.9GHz to 4.3GHz)
16GB, 2x8Gb, DDR4, 2666Mhz
2TB 7200RPM 3.5" SATA HDD
NVIDIA(R) GeForce(R) GTX 1650 SUPER 4GB GDDR6
 

ASK THE COMMUNITY