[SOLVED] Cannot Connect to WiFi on my Macbook Pro Retina Earl 2013, Running OSX Catalina 10.15.4

meeceit

Reputable
Oct 31, 2018
3
1
4,515
0
All of a sudden, I have lost connection to my wifi. When I try to connect, it tells me a WPA2 password is required. I have checked to make sure the password is correct in keychain, on both laptops. I have noticed that when I restart the Mac, as soon as it starts back up and I look in the top right corner at the WiFi option, it is turned off. I have to manually turn it on each time I restart or turn my computer off and then on again. I have two laptops, one of which I am typing this up on right now (a Macbook Pro Retina Mid 2015), and the Early 2013 model is the only one having this issue. I've done all of the troubleshooting steps I could think of, including:

  • Deleting (-) the network entirely via System Preferences > Network > Advanced, and re-adding the Network.
  • Adding Google's DNS Servers (8.8.8.8 & 8.8.4.4).
  • Under the TCP/IP tab, I changed Configure IPv4 from "Off" to "Using DHCP". This automatically reverted to off again, before I had the chance to do anything else.
  • Unplugged the router, waited 10 seconds, and plugged it back in.
I may have tried other troubleshooting steps, but this is what I can remember. I had a previous issue with my Mid 2015 Retina, but it was solved when I added the two Google DNS Servers above. It also did not automatically turn off the WiFi as it does on the Early 2013.

I am using an ATnT router, Model 5268ACFXN.

Any help would be greatly appreciated.
 

RamBoy_69

Prominent
Apr 17, 2020
103
10
715
32
Go to System Preferences on your Mac. Select "Network". Then on the left tab bar, make sure WiFi is selected and click the minus icon on the bottom of that tab. Then press the plus and click on the drop down menu. Select "WiFi", and then hit "Create". After doing so, press "Turn WiFi off" and restart your computer. Then turn WiFi on and connect to your network. If this doesn't help... I highly encourage you to please reply to this message.
 

meeceit

Reputable
Oct 31, 2018
3
1
4,515
0
Go to System Preferences on your Mac. Select "Network". Then on the left tab bar, make sure WiFi is selected and click the minus icon on the bottom of that tab. Then press the plus and click on the drop down menu. Select "WiFi", and then hit "Create". After doing so, press "Turn WiFi off" and restart your computer. Then turn WiFi on and connect to your network. If this doesn't help... I highly encourage you to please reply to this message.
I found out that it was my VPN causing an issue with the DNS. Thanks for the reply, though.
 
Reactions: RamBoy_69

ASK THE COMMUNITY