[SOLVED] Cannot Create Recovery Drive ??

stevwolf

Distinguished
Jul 30, 2010
36
0
18,530
1
I cannot create a recovery drive. The computer works find at the moment, but for the issues listed below.

Let me tell you what I have tried and the results.

I start Recovery Drive app.
Create a recovery drive.
I enable backup system files to the recovery drive. Put in 32 GB USB Drive.
It then grinds away and then shows the USB Drive to save the files to. It gives message about deleting everything, and then I say OK. It says, Formatting Drive, Copying utilities, Copying system.
It finishes with:
“We Can’t create the recovery drive – A problem occurred while creating the recovery drive"
When I run it without "backup system files" it runs ok.

Ok So here are the answers on line, all of which do not work for me.

Some Things I have tried based on various web sites that try to resolve this issue.

1. Long format drive before running – and run again, I did this. Still failed.
2. Elevated Command Prompt, type “run /scannow” It, stops at Verification 28% complete with message “Windows Resource Protection could not perform the requested operation.”
3. Tried running above command in Safe mode. Same errors as 2. Above.
4. “chkdsk C: /r” as administrator everything seemed fine although there was a message `”Failed to transfer logged message to the event log with status.” Still it seems to have not failed anywhere else. I have run this command several times and it takes a couple of hours but again no issues that I can see, and the computer continues to boot nicely.

5 Many people talked about “Change Security Descriptors” and running “ICACLS C:\Windows\winsxs” it seems to finish fine with message “Successfully processed 1 files: Failed processing 0 files
6 Booted into recovery mode and did a ‘start-up repair’ as some recommended. This basically did nothing and said it could not find anything.
7 Stopped and started service. “Windows Modules Installer” still can’t run /scannow or create recovery usb without errors listed above.
8 “Reagent /info” shows Enabled.
9 I run: “dism /online /cleanup-image /restorehealth” Below is the output. It stops at 52.7%
[===========================52.7% ]
Error: 4448
The WOF driver encountered a corruption in the compressed file's Resource Table.
The DISM log file can be found at C:\WINDOWS\Log\ISM\dism.log
Of could I could look at the log but not sure what I’m looking for?


10. One person to solve this new problem says to run troubleshooter on windows update, I did this but it found no errors.
11. sfc/SCANNOW /OFFBOOTDIR=c:\ /OFFWINDIR=c:\windows
However I get a curious error, >The aruguments passed to sfc are invalid. The offline windows directory specified points to the online system.

12. Some suggested to Ran “Windows Memory Diagnostic App” however this app seems to stick right off the bat. It does seem to be a flaky app, so I may try a better program. But I would think this is not the problem ??

So having said all that, I would be happy to have someone suggest what else to do. This is my main computer and I like to keep things up to date and working properly. Part of that is making sure all the backup programs like creating recovery USB works properly.

I have another computer that is almost the same and is running Win Pro 21h2. I have seen some people say to copy the \windows\WinSxS folder and files from working computer to the other. Would that fix it? And what program do I use to do that with, that would preserve all the permissions etc. Of course Im looking for simpler solutions ? What advice can you give?

Thank you.
 

stevwolf

Distinguished
Jul 30, 2010
36
0
18,530
1
Yes I have seen this in a few posts. I admit that Im hesitant, partially because its a long fix. But also worried about potential loss. I was hoping that this would be a last resort, if people had other suggestions. (Maybe Ive exhausted them all ??) BTW Yes my version of Windows is 21h2 19044.1466.
 

stevwolf

Distinguished
Jul 30, 2010
36
0
18,530
1
What is the differnce between what Im doing and a disk image, as far as recovery.
However it also based on my tests incicates something is not right.
 

stevwolf

Distinguished
Jul 30, 2010
36
0
18,530
1
Check health of your storage device. Use HDtune health, post screenshot.
(upload to imgur.com and post link)
HD Tune: Maxtor 6L300S0 Health
I think this is what you want.

ID Current Worst ThresholdData Status
(03) Spin Up Time 179 179 63 21887 Ok
(04) Start/Stop Count 253 253 0 122 Ok
(05) Reallocated Sector Count 253 253 63 0 Ok
(06) Read Channel Margin 253 253 100 0 Ok
(07) Seek Error Rate 253 252 0 0 Ok
(08) Seek Time Performance 246 239 187 46996 Ok
(09) Power On Hours Count 250 250 0 4108 Ok
(0A) Spin Retry Count 253 252 157 0 Ok
(0B) Calibration Retry Count 253 252 223 0 Ok
(0C) Power Cycle Count 253 253 0 148 Ok
(C0) Power Off Retract Count 253 253 0 0 Ok
(C1) Load Cycle Count 253 253 0 0 Ok
(C2) Temperature 43 253 0 39 Ok
(C3) Hardware ECC Recovered 253 252 0 10606 Ok
(C4) Reallocated Event Count 253 253 0 0 Ok
(C5) Current Pending Sector 253 253 0 0 Ok
(C6) Offline Uncorrectable 253 253 0 0 Ok
(C7) Ultra DMA CRC Error Count 199 199 0 0 Ok
(C8) Write Error Rate 253 252 0 0 Ok
(C9) TA Counter Detected 253 252 0 0 Ok
(CA) TA Counter Increased 253 252 0 0 Ok
(CB) Run Out Cancel 253 252 180 1 Ok
(CC) Soft ECC Correction 253 252 0 0 Ok
(CD) Thermal Asperity Rate 253 252 0 0 Ok
(CF) Spin High Current 253 252 0 0 Ok
(D0) Spin Buzz 253 252 0 0 Ok
(D1) Offline Seek Performance 240 240 0 156 Ok
(D2) (unknown attribute) 253 252 0 0 Ok
(D3) (unknown attribute) 253 252 0 0 Ok
(D4) (unknown attribute) 253 252 0 0 Ok

Power On Time : 4108
Health Status : Ok
 

stevwolf

Distinguished
Jul 30, 2010
36
0
18,530
1
That may be true, but then the computer is old too. If that is clearly the issue then that may be true. But is it ?? I have other computer exactly the same, probably drive just as old and it works find everything runs great. So picking on that I dont think ? is the issue. Something is wrong. I dont want to but new drive and discover the problem still exists. Ive dont this too many times.
 

stevwolf

Distinguished
Jul 30, 2010
36
0
18,530
1
Just to follow up on my results. So I tried copying the \windows\winsxs file from another computer. I used the method as follows from this web site: Copy WinSXS file to usb drive Solved - Windows 10 Forums (tenforums.com)

"If you have the two computers on the same WLAN or wired network, try sharing the C:\Windows\WINSXS folder on the "good" PC with "READ" for "Everyone" with a Share name of "WINSXS-Good", then open an Administrative Command Prompt on the "bad" computer and map a drive, let's use the letter "R" for "Repair" to the "good" computer, e.g.:

net use R: \\<goodcomputername>\WINSXS-Good <-- Obviously you need to replace <goodcomputername> with the appropriate one for the "good" computer.

Then on the "bad" computer use:

DISM /online /cleanup-image /restorehealth /source:R:

When that has finished, if all has gone though successfully, then run, (on the same computer):

SFC /SCANNOW
This process finished without any errors, Sadly it did not solve the problem. I still got errors running sfc.

So then I went with an in-place reinstall as mentioned at the beginning of this post. It actually was not as painful as I had imagined. The instructions were not as clear as I liked but to me the important steps were there. The steps are basically:

Download the media builder, onto USB or CD.



  • Do not boot from these, but rather once they are created go onto them via the File explorer and then run setup listed on the CD or USB. That was the part that confused me. I at first thought that you should boot from the CD or USB . But this is not what you do. You want to run setup from CD/USB while in windows. This is listed in the instructions from tenforums but I didnt quite understand that as I'm predisposed to booting from emergency disks.

  • Continue to follow the instructions from tenforums . Let it grind away installing OS.
  • When finished, everything worked like a charm, eg. no files were lost and now I can run SFC /scannnow without errors and did a "create recovery" fine without any errors. I didnt even have to put in a new key. Maybe becasuse mine is a digital copy ??? I dont know.


Anyway If this helps someone.
 

ASK THE COMMUNITY

TRENDING THREADS