Question Cannot delete partitions or clean any of the drives during a clean Windows 10 install

wytas2001

Reputable
Jan 10, 2018
10
0
4,520
1
I have a Lenovo Yoga 520-14IKB laptop that is stuck on a boot loop, the Lenovo logo shows up on the screen, something is loading and then the PC restarts. I tried a few things to fix this, they didn't work, so naturally, the next step is a clean Windows 10 reinstall.

On a separate PC, I downloaded the Media Creation Tool for Windows 10 and installed it onto a flash drive. Then I inserted the flash drive into the Lenovo laptop, got into BIOS, changed the boot order and started the Windows 10 installation.
I selected to do a clean install, but when I get to the stage where I need to delete all the available partitions in order ready the unallocated space for a clean Windows 10 install, I cannot delete a single one of the 5 partitions.

All of the partitions have the “Total size” and “Free space” column data matching, i.e. the single available drive that these partitions are on - Drive 0 - is empty.
When selecting any of the partitions, at the bottom of the “Where do you want to install Windows?” window I get a message that “Windows can't be installed on drive 0 partition _. (Show details)” and when the message is clicked on, it says that “Windows cannot be installed to this disk. The disk may fail soon. If other hard disks are available, install Windows to another location”.
If I try deleting any of the 5 partitions, a window pops up, saying “We couldn't delete the selected partition. [Error: 0x80070017]”.

I tried the “cmd>diskpart>list disk>select disk 0>clean” method while being on the first page of the Windows 10 installation. I get the message that “DiskPart has encountered an error: Data error (cyclic redundancy check)”.
I tried the “cmd>diskpart>list disk>select disk 0>list partition>select partition _> delete partition override” method, I get the same “DiskPart has encountered an error: Data error (cyclic redundancy check)” message.
I tried booting off a flash drive with a Seagate SeaTools (Bootable) tool installed on it. SeaTools launched, but failed to recognize the single existing Lenovo laptop's drive and only showed the same flash drive it came on.
I tried disabling Secure/Fast boot, the date in the BIOS is on point.

Nothing works. Is the drive dead? “cmd>diskpart>list disk>select disk 0>detail disk” information says the “Status” of the partitions is “Healthy”, if that changes anything.
Any help would be appreciated.
 
Last edited:

ASK THE COMMUNITY