Cannot For The Life Of Me Get My Steam Link Working!!!

Jaydon382

Commendable
Jan 2, 2017
50
0
1,630
0
Been at it for about Three Days now and I haven't been able to connect the steam link to my pc.

It says it's connecting and opens big picture mode on my pc just for it to close and kick me back to the connection page... as well as the screen on the steam link lets you move the mouse around and a black screen until then. If you try to test the network connection, it doesn't get past 0% and then it pops up a message to open port 27031.

I have tried:
Port Forwarding.
Adding the Ip address to allowed in Firewall as well as the modem's firewall.
Tried Both Wired and Wireless connection.

I have tried these solutions and/or recommendations/help articles:
https://support.steampowered.com/kb_article.php?ref=4950-EBNM-7843
https://steamcommunity.com/app/353380/discussions/0/142261027574034085
https://steamcommunity.com/app/353380/discussions/0/490125737466823803/
https://support.steampowered.com/kb_article.php?ref=9772-WHJM-4676
https://steamcommunity.com/app/353380/discussions/0/152390014795565465/
https://steamcommunity.com/app/353380/discussions/0/490125103641995031/#c490125103643202831
https://steamcommunity.com/app/353380/discussions/0/485622866450653962/
https://steamcommunity.com/app/353380/discussions/0/483367798506378739/

Please Help Me, I really don't want to wait a couple weeks for steam support to finally respond
just for them to have me do exactly what I have already tried.

Thank You!


Edit: Will be Posting Photos/Videos.

https://www.dropbox.com/sh/xwz9218z9wpyp47/AAAgQoYJ2qiAQGPvXLzg9D6_a?dl=0
 
Steam Link operates entirely within your LAN. So you shouldn't be changing anything on your modem (except maybe assigning static IP addresses).

The error you're getting sounds like the host computer's firewall is blocking Steam Link from connecting. Try temporarily disabling the firewall entirely on the host computer, to see if the problem goes away. If that works, then you need to modify that computer's firewall to allow connections via the ports listed in the first link you gave. Take care to allow TCP or UDP as listed, as they are different protocols and allowing one does not allow the other.
 

Similar threads


ASK THE COMMUNITY