Question Cannot get PC to give power to thr monitor after a weird dark green screen

May 11, 2020
Hi guys.

So about an hour ago I was gaming, and all of a sudden, a dark green screen with horizontal lines just appeared and at that point, I couldn't do anything. I had tried alt+f4, ctrl+alt+f4, alt+tab and also win+d before realising that the only thing left is to try to shut it off or restart it. I tried the shut down button, but nothing happened so I restarted it. Now here it gets even weirder, because right after the computer had shut down, it started back up normally, but neither my keyboard, mouse nor display turned on. The computer sounded totally normal, and every led light and fan was working as always. I tried shutting it off again, and it worked, but right after that it just booted itself back up again without me even touching anything, so I had to cut the power off in order to shut it down.

Here are all of the things I've tried since.

- I tried reconnecting my two ram sticks and rebooting right after. No success.

- I tried changing my cmos battery with the exact same one which had been powering the scale, and when I put the one from the motherboard into the scale, the scale didn't work, so I thought that this would surely fix my issue. No success.

- I saw somewhere that a possible fix is to wipe the cmos memory by rearranging the sockets on the pins, so I just moved both sockets to the right, so they both cover the 2nd and 3rd pin, as instructed in many videos, but to no avail. The PC wouldn't even turn on with that configuration.

- After that, I tried moving the sockets back to their original place, and I kept the new battery untouched, but still, no success.

I really have no clue how to fix this. The motherboard has a green light that is constanly on when the power is connected. The lights on the case also light up regularly.

Here are my components:
Motherboard: Asus h81m-c
Processor: Intel pentium 3ghz
RAM: Kingston HyperX Fury 4gb (2x)
GPU: Radeon RX 270

I don't know if any other specifics are required, but I am at my wit's end here...
Since I am on my phone, I cannot upload any pictures of the motherboard until I post it.