Question Cannot install drivers for Asus Strix Raid DLX sound card ?

Oct 15, 2020
8
0
10
0
Like I said I am unable to install the drivers for my Strix Raid DLX sound card that I installed earlier today. Took me 7 hours just to get audio to come through the control box and then I lost it again. I have no actual control of the audio because the drivers from both the cd and website both give me the error "The digital signiture of the object did not verify" and Sonic Studio just says the correct driver is not installed. I have tried everything I can think of and I really dont want to uninstall any more drivers seeing as I just got the audio working and dont want to risk losing it again. The only way I can get audio is if I plug my headset straight into the sound card.

After restarting my pc thismorning I am able to get sound through the control box again but I am still having the issue with the driver.

Here are some Images that might help, pictures of my PC and of the error messages.

View: https://imgur.com/a/lPpFIda
 
Last edited:
Oct 15, 2020
8
0
10
0
Have you updated the device to the latest firmware Version 1.14?
If you have not updated the device to the latest firmware, have you tried installing one of the earlier Driver Packages?
I am administrator and I have tried every driver available for my sound card they all have the same issue, my soundcard is not showing up as its own device in device manager however under sound, video and game controllers it has Strix Raid DLX and under audio input and output it has the same thing. When I view the driver for it the version its running is 17.25.12.490 from 2015 from A-Volute. I feel like I should be able to see my actual sound card somewhere in device manager but I cant, it appears to be working however because the audio is better quality and much louder.

I also just performed a clean boot and this did not fix the problem.
 
Last edited:
Oct 15, 2020
8
0
10
0
Weird --- no errors showing in your Device Manager --- sound card is clearly shown by name which suggests it's driver is successfully installed.
Doesn't seem to me to be a "drivers won't install" problem.
Did you see the other image with the error message?, Im just really unsure. I've tried so many things.
 

ASK THE COMMUNITY