Cannot load storage controller on ML150 G6

Shining_Lizard

Distinguished
Nov 23, 2009
39
0
18,540
Hey all, I'm currently setting up a HP Proliant ML150 G6 tower server with Windows Server 2008 R2 x64, but I have run into a problem.

Initially I attempted the installation via the HP Easy Setup CD, but the installation of the server OS would not complete as the DVD would be spat out when it got so far. According to HP support, this happens because the Easy Setup CD only works with Hyper-V versions of Windows Server. So, I opted to circumvent the Easy Setup and just install Windows Server on the blank system without it. The server has two 250GB drives, RAIDed with RAID 1+0, using HP SmartArray B110i.

The problem comes when, after I click "Install Windows" and agree to the license agreement and all that, setup cannot see any storage devices and it gives me the mesages that it cannot detect any storage drivers. I click to install some, but there aren't any. I put in the Easy Setup CD to find the drivers from there, but apparently the ones on there don't work either. I even downloaded the specific B110i drivers from HP's own website, but they are apparently not compatible and won't install.

I'm really at a loss here as to what to do, so some help would be very much appreciated.
 

Shining_Lizard

Distinguished
Nov 23, 2009
39
0
18,540
Ah, someone can close this, I solved it. Pulled down the drivers again to be sure they were correct, and put them on the root of a USB drive. Putting them on the root seems to be easier to find for the setup.