Cannot remove read only attribute

br6205

Distinguished
Jan 8, 2011
4
0
18,510
0
I did something that caused my greyed in read to not let me remove the check. I need to move the folder, because the drive is running out of space and , of course, I can't.
 

Saga Lout

Titan
Moderator




You need to use Command Prompt which you find from Start then Run and by typing cmd into the open box. At the prompt, type attrib /? then decide which of the switches applies to the command you want to execute - possibly -h and possibly -d for an entire folder.


 

br6205

Distinguished
Jan 8, 2011
4
0
18,510
0
TY for your comment, but I am sorry I don't understand how that will allow me to permanently remove the read only attribute to the folder I want to move.
 

Saga Lout

Titan
Moderator

I'm sorry I can't make it much clearer. The minus or dash switch removes an attribute as opposed to the + which adds one so the letter that follows a dash carries out the removal process.

You therefore need to key in attrib -r followed by the drive letter, path and filename and hit Enter and that removes the read only attribute from that filename. To deal with an entire folder you need to add d in the mix.

I recommended starting with the command attrib /? so that you can see which options are available and decide how best to go about it. The /? switch after a command always shows everything that can be done with that command.

I prefer wherever possible to show hoe things can be done rather than just how to do one particular job.