Cannot turn off G-sync on ROG Swift

Optimumz

Reputable
Mar 30, 2014
20
0
4,510
0
Basically i know you can choose graphical settings on nvidia control panel per game/application. and ive tried to lower my resolution for specific games (CS:GO to be precise) and still retain my 144htz refresh rate, but obviously i want t oplay full screen when playing at 720p etc, but using full screen on any games immediately forces v-sync/g-sync. on my game it says v-sync isnt enabled (id never use it unless i cant hit 150+ on a game, whatever i try it just doesnt seem to work. also i have 2 monitors (Swift, and VG248QE) and i have another problem. basically when i had a fresh install etc (only built this in november) i could have a video/browser on the VG248QE monitor and my game on the other, however when i did this after a fresh install i could do this with no performanmce issues. now when ido this i have high cpu usage from 'Desktop Window Maager' and i seem to be only able to view 30 fps however with fraps on i can see im getting 10+ easily whatever game its on, but i still have really jaggedy visuals. if anyone could help me with this id be greatly apprieciated. i have looked every where for a fix for this and i cant seem to find one thanks for reading.

Just incase its important. im running
4790k 4.5ghz
sli 980s 1.45ghz
win 8
16gb
 

CraigN

Honorable
Aug 15, 2013
1,436
0
11,960
367
If Shadowplay isn't running, try just killing DWM in Task Manager. You should notice some extra smoothness. Also, Shadowplay records *way* better than FRAPs if you have a 7-series card or better, just saying.

Make sure you disable G-Sync in the order I described. First from the uncheck box, then from the dropdown menu in Manage 3D Settings. You must do it in both. You can tell if it's off if the bottom right of your monitor where the power button is if the tiny LED is white instead of red. The giant ring under the monitor *is not* the G-Sync indicator, just to be clear. If you're having issues with G-Sync re-enabling itself *inside* Nvidia Control Panel, try doing a Clean Install on your Graphics Drivers. To do this, download the latest drivers from Nvidia.com, and then choose Custom Install. When it shows you what drivers will be installed, click the "Perform a Clean Install" checkbox. This may fix your issue, as I recently had a driver update that completely removed G-Sync functionality from my Control Panel, so maybe you're having the opposite problem.

And Yes, at 10 fps anything is hard to use, let alone the mouse. But your panel *can only refresh* at 144 Hz (1 frame every 1/144 seconds). If you go up to 150+ FPS, you won't perceive any faster mouse movement than 144 Fps, because your monitor is capped out.

This is also why 60 FPS on 144 Hz "looks" smoother than 60 FPS on 60 Hz. The monitor refreshes the frames faster (every 6.9 milliseconds vs every 16.67 milliseconds on a 60Hz screen) so you perceive smoother mouse movement. But once you're at the frame cap, going *higher* will not gain you anything. I'm not opposed to turning your resolution down to get as high as you can. I'm just saying, if you're already banging above 144, there's no point in *not* using G-Sync to reduce stuttering from framerate drops when, say, 3 grenades go off on screen during a match. My point is, there's literally no reason to *not* be using G-Sync if you have a card and monitor that support it, and are hitting 144 Frames in your games.
 

CraigN

Honorable
Aug 15, 2013
1,436
0
11,960
367
Question - Do you have Shadowplay ON, with Desktop Recording on? For some reason in the latest drivers, this has been causing very slow performance on the second monitor. If so, turn off Desktop Recording and kill DWM in Task Manager, or restart. This will solve your second screen lagginess issues, or at least did for me.

You must turn off G-SYNC in *two* locations in the Nvidia Control Panel. You must uncheck it on the GSync tab, and you have to turn it off in Manage 3D Settings. Scroll all the way down to Vertical Sync and you'll see an option that says "G-SYNC" with the Nvidia logo next to it. Select it, and drop it down to "Let the Application Decide" and click Apply. G-SYNC will now be off. You will have to check both boxes in later if you want to re-enable G-SYNC.

Curious though, why are you disabling it? I mean yes, G-Sync will framecap you at 144 FPS, but your eye won't tell the difference between 144 fps and 150+ fps. No, this isn't an argument on the condition of the human eye, etc. I mean that literally, your monitor can only refresh a frame once every 1/144 seconds (6.94 milliseconds). If you are pushing above 144 FPS, and you *are not using G-Sync*, you are just dropping those extra frames. This is part of what causes tearing to begin with.
 

Optimumz

Reputable
Mar 30, 2014
20
0
4,510
0


Thank you for replying, ive done the g sync disable before and ive tried it again, and i click apply and then its instantly back to g-sync enabled, ect. and no i dont play with shadowplay i dont find it useful atall really, i have fraps so i will see if theres anything i can do regarding the shadwoplay thing, and well i asked this question to a few cs go players and bascially it comes down to the more fps you have in a FPS (for eg) the smoother your mouse movements are, for example if youve ever played a game at like 10 fps you notice your mouse is VERY hard to use, the more fps the more smoother the mouse control basically, or maybe that could just be a theory but it does make sense, and yeah definitely i agree with the 144 htz argument but i dont see why its a bad thing to want more fps, and i dont really notice any tearing when playing i have in the past but since getting used to high refresh rates i really havnt noticed alot, im going to tinker around with my shadowplay settings ect and ill tell you what happens
 

CraigN

Honorable
Aug 15, 2013
1,436
0
11,960
367
If Shadowplay isn't running, try just killing DWM in Task Manager. You should notice some extra smoothness. Also, Shadowplay records *way* better than FRAPs if you have a 7-series card or better, just saying.

Make sure you disable G-Sync in the order I described. First from the uncheck box, then from the dropdown menu in Manage 3D Settings. You must do it in both. You can tell if it's off if the bottom right of your monitor where the power button is if the tiny LED is white instead of red. The giant ring under the monitor *is not* the G-Sync indicator, just to be clear. If you're having issues with G-Sync re-enabling itself *inside* Nvidia Control Panel, try doing a Clean Install on your Graphics Drivers. To do this, download the latest drivers from Nvidia.com, and then choose Custom Install. When it shows you what drivers will be installed, click the "Perform a Clean Install" checkbox. This may fix your issue, as I recently had a driver update that completely removed G-Sync functionality from my Control Panel, so maybe you're having the opposite problem.

And Yes, at 10 fps anything is hard to use, let alone the mouse. But your panel *can only refresh* at 144 Hz (1 frame every 1/144 seconds). If you go up to 150+ FPS, you won't perceive any faster mouse movement than 144 Fps, because your monitor is capped out.

This is also why 60 FPS on 144 Hz "looks" smoother than 60 FPS on 60 Hz. The monitor refreshes the frames faster (every 6.9 milliseconds vs every 16.67 milliseconds on a 60Hz screen) so you perceive smoother mouse movement. But once you're at the frame cap, going *higher* will not gain you anything. I'm not opposed to turning your resolution down to get as high as you can. I'm just saying, if you're already banging above 144, there's no point in *not* using G-Sync to reduce stuttering from framerate drops when, say, 3 grenades go off on screen during a match. My point is, there's literally no reason to *not* be using G-Sync if you have a card and monitor that support it, and are hitting 144 Frames in your games.
 

Optimumz

Reputable
Mar 30, 2014
20
0
4,510
0


i did what you said regarding DWM.exe and it worked perfectly so thank you very much, and yeah of course i kenw about the white LED indicator ect i dont even have light motion on, and i never notice myself dropping below 200 at 1440p it was more of a query than anything. my g sync issue hasnt been resolved ive done exactly what you said i think maybe im just missing something out or something im not entirely sure however its not a gigantic problem anyway and like you said its not ideal to turn off g-sync with this much horsepower anyway thanks alot for your help espeicially with the dwm problem ive had it for a while and not been able to fix it and its bugged me alot so i really appreciate it thanks alot for your help
 

CraigN

Honorable
Aug 15, 2013
1,436
0
11,960
367
I'm glad the DWM kill solved your issue. Hopefully it doesn't recur. If it does, I would still recommend the clean install of your graphics drivers. It solved a few of those wonky issues for me (including DWM randomly taking up a lot of CPU %) and hopefully it'll solve your GSync concerns.

And sorry, I didn't mean to presume you didn't know, just thought I'd cover all the bases, especially since I ran into a few people on the ASUS boards who thought the ring was supposed to change color, not the tiniest LED ever lol
 

Optimumz

Reputable
Mar 30, 2014
20
0
4,510
0


no offence taken, i appreciate the help, i definitely will do if i come across any issues, thanks a tonne for the help the world needs more people like you my friend
 

gggplaya

Distinguished


Thanks, this works for me. I had to send my G-Sync monitor away for dead pixels, so i'm using my 60hz monitor right now. But because i didn't disable G-Sync before unplugging and shipping out the monitor, it won't let me shut off gsync as that option is not listed in the control panel with my 60hz monitor plugged in.

Whenever the fps dipped below 60fps, it was doing something funny like 50fps felt more like 25fps and 40fps felt like 20.



 

ASK THE COMMUNITY

TRENDING THREADS