Question Cannot update BIOS of Sabertooth 990FX [Weird Issue]

Apr 4, 2021
1
0
10
0
Hi all,

I have Asus Sabertooth 990FX mobo and trying to update it's BIOS but no luck i couldn't.

I followed this (https://www.asus.com/us/support/FAQ/1008859/) thread and renamed .CAP file as 990FX.212 and also tried as 990FX.0212 but PC doesn't recognize these files.

Nevertheless i followed this (https://forums.tomshardware.com/threads/how-do-i-update-my-bios-with-a-new-driver-in-a-cap-file-format.1378070/) thread. I extracted the .CAP file and copied that to the flash drive (formatted as FAT32) and again PC couldn't recognize that file. Also i tried with .zip file but no luck again couldn't recognize.

Also i followed this (https://www.custompcreview.com/articles/guides/update-asus-motherboard-uefi-bios-guide/) thread but "again" same result. I tried with 3 USB flash thumb drives. All of them are same result.

Could you please help me about this issue? Any help would be appreciated..

Thanks in advance.

Kind Regards.
 
each time i've updated BIOS with my last 3 ASUS boards it had to be a .CAP file. i don't know who would recommend changing the file type.
it should come with a proper naming scheme directly from ASUS.

you are in the BIOS selecting to flash the new **.CAP file from a Fat32 USB drive?
is the flash drive recognized by the BIOS?
have you tried other USB ports?
have you updated this board's BIOS in the past?

there's a possiblility that ASUS' motherboard control software for this board has an alternative way to update the BIOS from within Windows. check their support downloads page for your board and see what control software they offer in the utilities section.
 

ASK THE COMMUNITY

TRENDING THREADS