Question Can't access Bios after Bios update.

May 23, 2020
Hey guys.

I'm new on here. So thank you for having me in what I've seen is a great community.

As for my issue. I finally finished my build last night so before doing anything else like installing windows. I updated my Bios. Might not have been the best option to do so soon. Because now after updating my bios when I power up my pc. everything powers up and spins etc and I get the splash screen where it tells me to press either Del or F2 to enter bios setup. Well everytime I'm pressing Del or F2 nothing is happening and I end up on a blank black screen.

It's like the boot up isn't recognising that I have pressed the Del button or the F2 button to open my Bios if that makes sense?

I have tried absolutely everything I can find and nothing seems to be working. I thought it could be because it's not reading the usb keyboard so I went out and bought a ps2 one and still nothing. I will list everything below what I've tried so far to fix my issue. Any help what so ever would be greatly appreciated.

Motherboard and CPU - ROG Strix x470-F Gaming / Ryzen 7 3700x

Things I have tried.
I have taken the battery out for 5 minutes.
I have Touched the two pins to what the booklet says shorts them to reset my bios.
I have taken the battery out and touched the - and + Sign to short it which I read on the Asus website.
I've pretty much done everything I've seen on videos on Youtube and also what I've read on here and other websites from the similar problems others have had.

Like I said guys. Any help what so ever would be greatly appreciative. I'm even going to go as far as paying the person who gets this sorted for me.

Thanks again guys also for taking the time to read my post.