[SOLVED] Can't access bios on 1800x+X370 and system doesn't boot into windows

Bloody George

Reputable
Sep 3, 2015
22
0
4,510
BR
Hi folks!
My friend has had a burning hot Ryzen 7 1800x that constantly crashes and turns off for over a year now. The CPU stays in 40-60C idle, and goes up to 80C when gaming and video editing. He told me it crashes in some games and turns off suddenly when rendering videos on Premiere Pro. I'm visiting him now and decided to turn off SMT on the BIOS just to see if it would improve the temps. Now the PC takes over 5min just to get to post and never boots into windows 10. I also can't open the BIOS as the screen just blacks out and the fans keep spinning with lights on and everything.
Now I don't know what to do. I've tinkered with BIOS many times before, have an OCed 6600k myself. This has never happened to me.

Can you help me out? I hope I didn't cause any damage to his pc.

Specs:
Ryzen 7 1800x + simple 12mm watercooler
MSI X370 SLI Plus
MSI GTX 1070ti
Corsair CX650
16GB Corsair Vengeance RGB at 3000mhz
 
Have you tried clearing the cmos?
There should be a jumper on the motherboard that you have to bridge with a screwdriver for a few seconds when the system is powered off but plugged in.
For cooling issues i would apply new thermal paste to cpu and make sure the cooler has adaquate airflow. A tiny 120mm aio wouldnt be my first choice on an overclockable 8 core.
 
Last edited:

Bloody George

Reputable
Sep 3, 2015
22
0
4,510
BR
I'm so paranoid that I don't know if I should risk anything like that. Does it have the same effects as removing the battery and putting it back in? Are there any risks in any of the methods?
 

ASK THE COMMUNITY

TRENDING THREADS