Can't access my Seagate Backup Plus External Hard Drive.

fafhrd

Honorable
Apr 11, 2013
1
0
10,510
0
I tripped on the cable connecting my 3tb Seagate Backup Plus HDD, and disconnected it from my pc. It was popping in and out, disconnecting on its own then. A few days ago I got the message about data corrupted and didn't think much of it, until I plugged the drive back in and it asked me to format it. It listed the drive as local, and when I rt clicked on it, it would say Windows can't access.

So I tried a different cable, pc, and other usb ports, still can't access it. When I virus checked it, I could see the names of files. I ran chkdsk /f and chkdsk /r, and I could see the folders in there, but still couldn't access it. I tried changing the drive letter from e: to j:, no luck. Under disk management in admin tools, I can see the drive and it says 2.47 tb used with 260 gb free. I have tried taking ownership (windows 7) but I got locked in when I allowed full control for my user name from special permissions.

I ran Easeus Data Recovery and it won't show the drive. Same thing with recuva. Then I went to full recovery in Easeus, import, and when I accessed the Computer folder all the folders from that hard drive showed up but with a lock on them. Obviously they are there, but I can't access them. Or make them reappear, or access the drive I guess.

I ordered a universal drive adapter thinking that might help but in the meantime I would be hugely grateful for some help. It is really stressing me to lose all the data and I can't justify spending hundreds to take it to a service.

Thank you in advance,
Justin
 

Similar threads


TRENDING THREADS