Can't access MyCloudEX2 drive in Win10 File Explorer

glcaan99

Distinguished
Sep 8, 2010
22
0
18,510
0
Recently purchased a WD MyCloud EX2 Ultra NAS drive. Was able to set up drive and can access drive in Dashboard, modify settings etc. The drive shows up in File Explorer under Network as MYCLOUDEX2ULTRA, but when I attempt to open it get an error message:

Windows cannot access \\MYCLOUDEX2ULTRA

Did some research and have tried several things so far:

- Configured router to reserve IP address for MyCloud drive.
- Set up shortcut to IP address on desktop. Note I CAN access drive through this shortcut.
- Windows is up to date, update KB3140743 successfully installed on 3/1/16, which apparently addressed this issue for some users.
- Selected "Enable NetBIOS over TCP/IP" in Network Adapter settings.
- Verified network is Private.
- Rebooted drive and PC.
- Tried to map network drive using IP address. IP address not recognized.
- Drive is set up where I am administrator (user name "admin"). Disabled password and still can't open in Explorer.

So I can manually access the drive through a desktop shortcut but cannot open it in Explorer, or map the drive. Appreciate any suggestions. Thanks!

 
Hey there, @glcaan99!

I'm sorry to hear about your issues with your new WD MyCloud EX 2 Ultra! :( You have done a very good job with the troubleshooting steps so far! I'd also suggest you go to the Dashboard of the My Cloud device and click on the Settings > Network. At the bottom of the settings, you should be able to see Windows Services. Make sure you change the setting of MAX SMB Protocol from the default SMB2 to SMB1.

Hope this helps.
Let me know how it goes!
SuperSoph_WD
 
Hey there, @glcaan99!

I'm sorry to hear about your issues with your new WD MyCloud EX 2 Ultra! :( You have done a very good job with the troubleshooting steps so far! I'd also suggest you go to the Dashboard of the My Cloud device and click on the Settings > Network. At the bottom of the settings, you should be able to see Windows Services. Make sure you change the setting of MAX SMB Protocol from the default SMB2 to SMB1.

Hope this helps.
Let me know how it goes!
SuperSoph_WD
 

glcaan99

Distinguished
Sep 8, 2010
22
0
18,510
0


Hi SuperSoph_WD,

Thanks for the feedback. I will definitely give this a try. Had a question- I'm not very familiar with these Samba protocols; will it degrade performance of the drive is I change this setting from SMB2 to SMB1?

Thanks again!
glcaan99
 
Hey there again, @glcaan99!

Actually, you could also try to configure the Max SMB Protocol to SMB3 as the WD My Cloud EX2 Ultra series should be supporting it and it's backwards compatible with SMB2. In terms of data transport, it should give you a much better performance. Moreover, it could prevent any more issues with the file access locally or remotely.
Here's an article from our knowledge base that can assist you with this configuration.
Here are some additional links that might help you get more info about the Samba protocols:
1. Which version of the SMB protocol
2. Samba3/SMB2

Good luck! Hope it helps.
SuperSoph_WD
 
Jun 26, 2018
1
0
10
0
I’ve tried everything, possibly and imaginable,I’ve tried everything I’ve googled. Even Microsoft Level 2 Tech, couldn’t find a solution. I was able to get it working by changing the SMB1 to SMB3 under the network settings for MycloudEX2ultra. Thank you so much for your help!!!
 

ASK THE COMMUNITY

TRENDING THREADS