Question Can't access UEFI/BIOS settings on MSI AG240-2PE (just get black screen) ?

Feb 8, 2021
1
0
10
0
Hi all,

I'm going to tell you about an issue I have with my AIO MSI AG240-2PE computer. I'm trying to enter to UEFI/BIOS settings from boot. When I press F11 key after MSI logo it goes to black screen (slightly retro-illuminated) and computer doesn't respond so I have to long press power on/off button. Same result if I try to enter by Windows 10 -> Configuration menu -> Security and Update -> Recovery -> Advanced startup.
With all the machine boots fine. I have a dual boot Windows 10 + Linux without problems.
I think that if I could find where is the CMOS internal battery I could solve the issue but I tried to dissasemble the PC and I can't find out where is the CMOS battery because I can only access to SATA and RAM banks. Dissasembling the rest is very very difficult.
I've tried to reflash the latest BIOS firmware too but I've seen it runs the latest one and to reflash I have to enter in FreeDOS mode. The problems is I can't boot into FreeDOS mode because the machine only boots in UEFI mode and FreeDOS cannot boot.
I asked for help in MSI supoort a time ago but they only advice me to carry it to a technical service ...

Has anyone suffer the same issue than me? Any advice?

Thanks in advance. Regards.
 

ASK THE COMMUNITY

TRENDING THREADS