Question cant belive my cpu is dead by this easy? recently i overcloacked my cpu to 4.8 ghz with 1.330 and saved settings and then boom screen goes black

Nov 3, 2020
6
0
10
0
recently i overcloacked my cpu to 4.8Ghz with 1.330 voltage and then boom screen goes only no signal but pc running fan spinning keyboard mouse led up nothing on ez debug i tryied literally every single solution and neither of them worked tryied pull out battery or reset cmos and cheacked every single part and every part is good i tryied to pull out the gpu and put the display port to the motherboard still nothing and i EVEN BOUGHT a new mobo and still not worked and even bought a new psu still not worked my specs are
I5 9600K
MSI Z390 A PRO
Water cooling
Asus strix gtx 1080
16GB DDR4 2400mhz
my question is did i really fryied my cpu this easly? i can fell some temperature from it is that mean its working ?!
 
Nov 3, 2020
6
0
10
0
You could of overclocked your cpu to much till the point its broken!
no i only overcloacked it 2 timis in its life span to 5ghz and 1.350 voltage and it was not stable and i put it back to normal but recently i overcloacked it to 4.8 ghz and 1.330 i dont know if i fryied my cpu
 
no i only overcloacked it 2 timis in its life span to 5ghz and 1.350 voltage and it was not stable and i put it back to normal but recently i overcloacked it to 4.8 ghz and 1.330 i dont know if i fryied my cpu
You have tried new motherboard and new PSU and both times there having black screen, so maybe its the overclock that gone wrong and cant tell if you fried it but could be overheated!. Best advice is to stop replacing stuff and just replace the CPU or maybe get an cpu that can do 5ghz
 
Nov 3, 2020
6
0
10
0
You tried everything


You have tried new motherboard and new PSU and both times there having black screen, so maybe its the overclock that gone wrong and cant tell if you fried it but could be overheated!
lol i cheacked every part but i still cant belive it dead this easly💔💔 but thx for ur help 😊
 

Schlachtwolf

Commendable
Jun 22, 2019
571
138
1,390
88
What is your "Water cooling" solution, a custom loop or an AIO, did you check temps while attempting the OC? Your voltage was in the green so unlikely killed it that way....but if your cooler was not properly seated it may have died. Can you bring the CPU to a PC shop where they could check it?

You need the display coming from the GÜU to get a display with that GPU. If you are useing say an 120mm AIO it may not be big enough to keep it stable but unlikely to kill the CPU altogether.... strange.... could also be you fried the VRM controller and your RAM is out so you can't boot, does the Mobo have any red, yellow or white lights on anywhere?
 
Last edited:

Pitbull Tyson

BANNED
Oct 28, 2020
38
6
35
0
That is not a voltage to kill a CPU. Also your PC should shutdown by itself when CPU reaching TJ MAX and above. So honestly I don' think you bricked the CPU. Perhaps the motherboard socket got botched or a VRM went bad or something. You can not set it to 1.35v and kill it that easy. So something else is going on.
 
Reactions: PrinceTexasLoaf

ASK THE COMMUNITY

TRENDING THREADS