Question Can't boot a bootable Red Hat ISO from SSD

Aug 24, 2020
11
1
15
0
I cannot figure out why this isn't working, hoping others might have some insight.

I have an 8 GB bootable ISO and I'm trying to get it to boot off of a 190 TB SSD. The SSD currently lives on a workstation, and can be taken in and out the workstation on a hard drive sled.

The ISO is a Red Hat Linux ISO (RHEL7) and the OS that I've used to format the SSD is RHEL 7 too.

Red Hat has virtualization software called QEMU/KVM (think like VMWare) and I can build a CentOS7 VM, and place that ISO to be booted up from the VM and the ISO boots up and works as intended.

Since this SSD is so large, I've restored to using gdisk/parted, as the tradition partition software, fdisk, has a 2 TB limit.

I've even tried to use a USB to SATA converter, instead of the hard drive sled, to copy the ISO over to the SSD, and then try to boot off of the SSD and still no success.

Am I missing a step or steps in order to get this SSD to be bootable?

Is this SSD simply to large to boot off of a 8 GB ISO?

thanks
 
It's not even clear what you want to do, if you want to boot into red hat iso you need a way to boot into it, as you said it comes with qemu so you have to run that to boot red hat.
Newer UEFI bios has the feature to boot up from a virtual disk file, you can add that to the windows boot menu and if the vdf has red hat installed on it it will boot it, probably. You can also add iso files to the boot menu as a last resort.
https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/boot-to-vhd--native-boot--add-a-virtual-hard-disk-to-the-boot-menu
 

ASK THE COMMUNITY

TRENDING THREADS