can't boot after switching driver to AHCI in windows

Status
Not open for further replies.

ungovernable

Distinguished
BANNED
Apr 14, 2011
456
0
18,780
0
I have a SSD and tried to switch to AHCI without having to reinstall. A guide suggested i had to do to device managers and then select my IDE items, select manually install driver and install the driver for AHCI

Well now i can't boot windows 8 anymore. I get an error message before the loading is finished, and i don't even have the time to read it my computer will instantly reboot and do the same thing over and over again

Setting the BIOS to AHCI will just cause another error. Windows8 won't boot and will tell me i need to repair it.

What can i do to fix it ?

Automatic repair from install CD isn't helpful. I don't have any system restore point.
 

rjackowens

Honorable
Jul 27, 2012
238
0
10,710
12
Well, it sounds to me like it may be corrupted. There isn't really a simple way to recover data from a corrupted hard drive, it may be best to reinstall Windows. If the data is extremely important, maybe the best thing to do would be to take it to company that recovers damaged data? I am sorry, but I don't know what else there is to do.
 

Tseg

Honorable
Jun 11, 2013
132
0
10,710
9
Hmmm, messing with the drivers. I was never that adventurous when trying to change to AHCI after my OS Install.

I know you do not want to do a fresh install. Windows 8 offers the Refresh option and the Reset option, either through the system (which you cannot enter) or through the W8 Recovery disk. I used the Reset option, because this all happened to me when my computer was new, so I had little to lose, but in hindsight, I think it can be done with the Refresh option.

I guess the question is, did you ever make a Windows 8 recovery disk (not an OEM recovery disk)?

-Install your recovery disc (made through the Windows Control Panel Backup area vs. the OEM recovery disk... should end up being 1 DVD)

- Go into BIOS at restart and change to AHCI and move the Boot from DVD option ahead of the Boot from HDD option

- System should go to a recovery screen generated from the DVD

- Press the correct option to run Refresh

- When refresh is complete, your system should be booting with AHCI

A Refresh keeps your Metro Apps but deletes all disk and downloaded programs... so they would all have to be reinstalled. The Refresh process took me 1 hour from disk insertion to reboot. The Reset option, on the other hand, was about an 8 hour process.

This is my only suggestion but a worthless suggestion if you did not make a W8 recovery disk.

 
There is a simple registry tweak that needs to be done besides setting ahci in bios.

Try and let windows repair work. If it works and you can boot again this is what you need to do.

Press windows + R key, type regedit, then navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msahci. Then right-click the word Start on the right-side and click Modify. Change the value in the window to "0" and click OK. Exit Regedit, reboot the system into BIOS, and change your sata controller to AHCI; save and exit BIOS and you will boot right into Windows.

To change back to IDE, follow the same steps reversing everything you did.

Edit:
Set your system back to IDE in BIOS and let system repair try to fix the system.
 

Kalle Karlsson

Honorable
Jan 9, 2014
1
0
10,510
0


Love U man!
Thanks a bunch, now my computer works in AHCI mode.
BR,
K
 

skyhack

Reputable
Apr 19, 2014
1
0
4,510
0
Here's some additional info if the registry fix doesn't work -

Check your /Windows/INF folder for a file named "msahci.inf". If it's there, the rest of this post probably won't help, but, WTH.

Boot to your old configuration (if you can) and download the AHCI drivers for your chipset. Once you download them, unzip the install with 7zip or a similar utility, to a new folder (7zip will pick a name for you). You should see a folder with the name of the original file on it. Drill down to the IA32 or 64 bit folders, depending on whether you're 32 or 64 bit, rename the AHCI.inf (it could be inAHCI.inf, amdAHCI.inf, etc) to msahci.inf and copy all the files in it to your /Windows/inf/ folder.

Now, do the registry hacks discussed above.

Reboot, and set the BIOS to AHCI. Windows will "see" the msahci.inf and access the third party driver. Once you're in, you may have to reboot a couple of times to get all of your drivers switched over.

The problem with the RAID install on my machine was there was no "msahci.inf" in my INF folder, so Windows didn't know what to do with my AHCI setup after switching from RAID.

This worked on my Dell Precision M6500, and saved me a ton of time.
 

Red8

Honorable
Jul 21, 2013
511
0
11,010
8


Omg thanks sooooooooo much, after some hours of digging I found this lovely post a and now I can run my wd hhd and Samsung 840evo ssd! I'm sooooo thankful! Your amazing!
 
Status
Not open for further replies.

Similar threads


ASK THE COMMUNITY

TRENDING THREADS