Cant boot system, cant even enter bios!! Help!

Nov 8, 2018
3
0
10
0
I need help!! I cant start my PC :-(

I was trying to install linux (ubuntu and mint) on dualboot along with Windows 10, but there were big screen tearing in linux and then system crashed and couldnt be booted. I tried it few times with same result but in first attempts I managed to change boot system back to windows boot manager, although it was mess here (there still was visible more window boot managers and ubuntu boot system although the linux was already removed).
In last attemp I was thinking if I can disable AMD card in BIOS, so I powered off PC and hold power button for some seconds (which is one way how to enter BIOS) but this time it seems the BIOS has broken somehow and I cant even enter BIOS!! Now when I start PC I dont even see MSI logo, only black screen with BIOS version at bottom (but CPU and GPU seems to be running)

I tried reseting BIOS by removing battery and connecting some jumpers, but nothing help.. Pleaase help.

My PC configuration:
MSI B85-G43 GAMING - Intel B85
MSI R9 390 Gaming 8G
Seasonic S12II-620W
Intel Core i5-4460
Crucial Ballistix Sport 2x4GB
WD Blue EX - 1TB
SSD 256
Zalman Z1
 

Lutfij

Titan
Moderator
Breadboard the system. You should be able to work off the iGPU. Remove the CMOS battery and replace after 15 mins. See if you can get into BIOS. How old is your PSU? You may also want to borrow a similar (quality)unit from a friend and see if the unit you have is the culprit.
 
Nov 8, 2018
3
0
10
0


I did remove battery and put it back after 15 or more mins.

Now when I start PC, there is black screen, I dont even see that BIOS version text on the bottom right, which I saw before.

PSU is 3 years old, I dont have other right now.

So what will be the next steps? Try to start it without RAM/GPU?
 

ASK THE COMMUNITY

TRENDING THREADS