[SOLVED] Cant boot to Nvme storage

Jan 15, 2022
20
0
10
0
So I accidentally installed windows to my hdd and so I unplugged that drive and tried to reinstall on my nvme drive. I booted from a usb stick with windows installation media and installed windows on the nvme drive but after it restarts it’ll just go back to the windows installation and it won’t boot from the nvme drive. The motherboard I have is a Gigabyte b550m ds3h.
 

USAFRet

Titan
Moderator
Mar 16, 2013
154,910
11,331
176,090
24,162
So I accidentally installed windows to my hdd and so I unplugged that drive and tried to reinstall on my nvme drive. I booted from a usb stick with windows installation media and installed windows on the nvme drive but after it restarts it’ll just go back to the windows installation and it won’t boot from the nvme drive. The motherboard I have is a Gigabyte b550m ds3h.
When it wants to restart, remove the install USB.
 
You said you installed windows on nvme drive already (with hdd disconnected).
If it doesn't boot, then you have inappropriate boot settings.

Can you show a screenshot from your BIOS boot priority screen?
(upload to imgur.com and post link)
 
Boot option #1 - change it to Windows boot manager.

If you don't have option to change to windows boot manager, then
boot from windows installation media,
go into command prompt (press Shift+F10),
execute following and show command output:
diskpart
list disk
select disk 0
list partition
list volume
 
Looks good.
1TB drive is partitioned in GPT. It's UEFI install.
It has a separate EFI system partition. Should be able to boot.

Only thing required from you - change boot priority settings.

May need to disable secure boot in BIOS (edit: with CSM enabled, this is not applicable).
Also disable fast boot (edit: it's already disabled in the screenshot).
 
Jan 15, 2022
20
0
10
0
Looks good.
1TB drive is partitioned in GPT. It's UEFI install.
It has a separate EFI system partition. Should be able to boot.

Only thing required from you - change boot priority settings.

May need to disable secure boot in BIOS (edit: with CSM enabled, this is not applicable).
Also disable fast boot (edit: it's already disabled in the screenshot).
I disabled secure boot and restarted and I still only have the usb flash drive as a boot option.
 
Hmm.
Might be necessary to repair bootloader.

Boot from windows installation media into command prompt.
Execute following and show command output.
diskpart
list disk
select disk 1
(select 1TB SSD)​
list partition
select partition 1
(select 300MB EFI system partition)​
assign letter=H
exit
bcdboot C:\windows /s H: /f UEFI
bootsect /nt60 H: /force
If everything is good and there are no errors, then boot into BIOS.
Should be able to change boot option to windows boot manager.
 
Jan 15, 2022
20
0
10
0
You got error on the last command. Something wrong with sector sizes.

Reinstall windows. This time clean target before installing. Use diskpart clean method.

I cleaned the disk and reinstalled windows. I went back to the command promt and the sector size error was still happening when I entered the commands again.
 

ASK THE COMMUNITY