Oct 13, 2020
6
0
10
0
Hello I have recently upgraded a few parts of my PC I upgraded to the Asus x570 Rog strix motherboard and a ryzen 7 5800 X I installed everything into a new case and everything turns on but I cannot get past the BIOS screen I can see that I have a boot device everything else looks fine but it will not get passes I have also already updated the motherboard to support the new processor is there any other areas I should check?
 
Oct 13, 2020
6
0
10
0
System specs are ryzen 7 5800 X G-Force GTX 1070 card 48 GB gddr5 Ram Asus Rog strix x570 gaming motherboard deepcool Captain Pro V2 cooler 128 GB SSD which I use for my boot and an 8 GB regular hard drive and my operating system should still be on my hard drives as I all I did was upgrade a couple parts I upgraded the motherboard and the processor and just put everything into a new case when every time I turn the computer on it goes straight to the BIOS menu I have everything updated so I'm not sure why I can't boot through this I see that my hard drive is there but I'm not sure if it's being detected
 
Oct 13, 2020
6
0
10
0
System specs are ryzen 7 5800 X G-Force GTX 1070 card 48 GB gddr5 Ram Asus Rog strix x570 gaming motherboard deepcool Captain Pro V2 cooler 128 GB SSD which I use for my boot and an 8 GB regular hard drive and my operating system should still be on my hard drives as I all I did was upgrade a couple parts I upgraded the motherboard and the processor and just put everything into a new case when every time I turn the computer on it goes straight to the BIOS menu I have everything updated so I'm not sure why I can't boot through this I see that my hard drive is there but I'm not sure if it's being detected
I have videos of what's happening but I can't seem to post that to this thread for you guys to see
 

ASK THE COMMUNITY