Can't change HD from PIO to UDMA

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hello everyone.

You guys and gals are my last hope.

One fine day my PC started responding very slow. Even menus would take
seconds before poping up. Soon I realised that it was my hard drive.

I have checked the IDE ATA/ATAPI controler and it's correctly stating that
it's using the Intel's appropriate driver which I installed myself when I
assembled the PC.

When checking the Primary and IDE channels I see that device 0 (which is my
primary HD) is set to "DMA if available" yet the current mode is "PIO Mode".
Device 1 (my DVD Drive) is also set to "DMA if available" and its current
mode is "UDMA 2".

The Secondary IDE Channels are also set to "DMA if available" and device 0
(my DVD Recorder) uses PIO Mode while device 1 (my old HD) uses "UDMA 4".

I have checked my BIOS setup and everything is set to auto and according to
its manual it should use UDMA if available.

I have bought brand new cables and I replaced the old ones but my main hard
disk is still very slow.
I have downloaded all kinds of checking utilities including those from the
HD vendor and they are reporting that both my HDs are in good working
condition.

I am getting a little dissappointed because I have tried everything I could
think off. I have even uninstalled almost everything I could, cleaned the
registry, defragmented the HDs and ran Scandisk. I have checked for viri and
malware (dialers/cookies/younameit). Nothing.

From a vendor's site (I believe it was MS knowledge base but I honestly
dont' remember) I remember reading that if there is over a number of CRC
errors (6 I think) Windows will downgrade the HD mode. Whatever the case my
main HD is running in PIO mode when DMA is available.

Any ideas why is that? What can I do make my main HD run in UDMA mode as it
should?

Best Regards
Nick

PS
I have also checked the jumper settings (slave/master etc etc)

PS2
Are there any programs which check what transfer modes are available to a
PCs devices?
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

There are two possible reasons that I can think of. First, double check
your BIOS settings to make sure there is not a cutom setting that is
limiting the drive. Second, try using different/older/newer drivers for
your *chipset*. You mentioned Intel, but you may want to double check
who makes the chipset/motherboard, and try updating those drivers.
Also, you can always try updating your BIOS which may be causing the
problem as well ;)

-----
Nathan McNulty
Swap gmail with name for email :)

Nick Zaglanikis wrote:
> Hello everyone.
>
> You guys and gals are my last hope.
>
> One fine day my PC started responding very slow. Even menus would take
> seconds before poping up. Soon I realised that it was my hard drive.
>
> I have checked the IDE ATA/ATAPI controler and it's correctly stating that
> it's using the Intel's appropriate driver which I installed myself when I
> assembled the PC.
>
> When checking the Primary and IDE channels I see that device 0 (which is my
> primary HD) is set to "DMA if available" yet the current mode is "PIO Mode".
> Device 1 (my DVD Drive) is also set to "DMA if available" and its current
> mode is "UDMA 2".
>
> The Secondary IDE Channels are also set to "DMA if available" and device 0
> (my DVD Recorder) uses PIO Mode while device 1 (my old HD) uses "UDMA 4".
>
> I have checked my BIOS setup and everything is set to auto and according to
> its manual it should use UDMA if available.
>
> I have bought brand new cables and I replaced the old ones but my main hard
> disk is still very slow.
> I have downloaded all kinds of checking utilities including those from the
> HD vendor and they are reporting that both my HDs are in good working
> condition.
>
> I am getting a little dissappointed because I have tried everything I could
> think off. I have even uninstalled almost everything I could, cleaned the
> registry, defragmented the HDs and ran Scandisk. I have checked for viri and
> malware (dialers/cookies/younameit). Nothing.
>
> From a vendor's site (I believe it was MS knowledge base but I honestly
> dont' remember) I remember reading that if there is over a number of CRC
> errors (6 I think) Windows will downgrade the HD mode. Whatever the case my
> main HD is running in PIO mode when DMA is available.
>
> Any ideas why is that? What can I do make my main HD run in UDMA mode as it
> should?
>
> Best Regards
> Nick
>
> PS
> I have also checked the jumper settings (slave/master etc etc)
>
> PS2
> Are there any programs which check what transfer modes are available to a
> PCs devices?
>
>