Question Can't connect old monitor to GTX 1660

davesp

Reputable
Dec 10, 2015
21
0
4,510
0
Trying to connect a Philips 202EL (has DVI-D and VGA ports) to my GTX 1660 using a DP to DVI-D cable. It works fine for a few seconds when the PC is posting, but then I get a 'no signal' message from the monitor.

When connecting a second monitor to the GPU (some Toshiba tv using an HDMI to HDMI cable) and looking in the Windows display settings and Nvidia control panel, the Philips monitor is not detected. It's also not detected when trying the 'detect older monitors' button in both Win display settings and Nvidia control panel.

I tried all 3 DP ports on the GPU, made sure the monitor input is set to DVI, and made sure the cable is securely connected on both ends. Also I know the Philips monitor works fine because I can connect it to my laptop (has an 860M) with the DP to DVI-D cable and it works fine.

Can anyone please help? Thanks.
 
Aug 26, 2019
15
0
10
0
The same problem, I think it's a monitor problem instead of the cable because I tried it on my old Samsung SyncMaster and I didn't get a No Signal but Windows does not detect it but detects when I use HDMI to HDMI, maybe it could also because of the cable, I'm not sure but I don't think DVI to HDMI works all the time with every monitor or system. But I can't guarantee any of the points I made were the problem.

https://forums.tomshardware.com/threads/i-cant-connect-my-laptop-to-my-monitor.3517434/

You can try this thread if you want.
 

davesp

Reputable
Dec 10, 2015
21
0
4,510
0
The same problem, I think it's a monitor problem instead of the cable because I tried it on my old Samsung SyncMaster and I didn't get a No Signal but Windows does not detect it but detects when I use HDMI to HDMI, maybe it could also because of the cable, I'm not sure but I don't think DVI to HDMI works all the time with every monitor or system. But I can't guarantee any of the points I made were the problem.

https://forums.tomshardware.com/threads/i-cant-connect-my-laptop-to-my-monitor.3517434/

You can try this thread if you want.
Thanks, but it's not a problem with the cable or monitor. They are both working fine when connected to my laptop. It's clearly an issue with the GPU not accepting the DVI-D signal for some reason.
 

ASK THE COMMUNITY

TRENDING THREADS