• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Can't connect to the internet through my TP-Link router

Jul 13, 2020
2
0
10
0
Hi,

I have a TP-Link TL-WR720N router. I recently got a new internet connection installed. The network configuration is like this: the ISP provided a cable from their modem/switch (not sure) on the lampost out on the street, which goes into the WAN port of my router, and through which I am using a wired connection to my desktop computer, and wireless to phones, laptops etc.

It took the ISP a lot of time getting the internet to work through the router and they kept complaining it's due to compatibility issues that their connection often experiences with these older routers, but they finally got it working. It worked fine for 3 days, then went dead for 2 days. During this time, I could access the internet through my laptop by connecting the WAN cable directly to my laptop just fine, but the router just couldn't connect to the internet even though all the correct lights glow up. (None of my devices could access the internet through the router, i.e. smartphones, desktop computer, laptop etc.)

Last night, it started working again and I am currently connected to the internet through the router actually, but I don't know how long it will last before it starts giving the same problem again. I just don't understand what the problem is. I tried everything i.e. power cycling, cloning router MAC address, factory reset etc. but when it doesn't want to work, it just won't work, try all you might.

The system log of the router always reads this when it is unable to connect:

INFO 2006-01-01 08:00:02|System: The device initialization succeeded.
INFO 2006-01-01 08:00:03|PPPoE: Automatically dialing.
INFO 2006-01-01 08:00:03|PPPoE: Sending PADI.
INFO 2006-01-01 08:00:05|PPPoE: Sending PADI.
INFO 2006-01-01 08:00:08|PPPoE: Sending PADI.
INFO 2006-01-01 08:00:12|PPPoE: Sending PADI.
INFO 2006-01-01 08:00:12|PPPOE: request timeout.
INFO 2006-01-01 08:00:12|Failed to connect to ISP server, maybe WAN port cable is unplugged.

But the WAN port is securely plugged in. Even the internet light glows up fine when the cable is plugged in the router. Nor is there any issue with the cable since I am able to access the internet when I bypass the router and directly connect the cable to my laptop.

But surprisingly, when it started working again last night, I just unplugged the WAN port cable and put it back in (had already tried this dozens of times before to no avail). This time it worked. I am not sure if this is what actually CAUSED the fix, it could simply be coincidental.

I am sure there is nothing wrong with the router's hardware, I've been using it for 3 years without such issues with my previous ISPs. I can't help but shake off the feeling that this is a configuration issue somehow and my router is unable to communicate with the ISP when they restart their servers or if there is change or shuffle in the settings from the provider's end which perhaps causes a conflict with my current router settings. But when it's a particular setting, it works fine (these are all wild guesses from someone who knows nothing about networking, so I apologize).

The ISP told me they can set up a newer TP-Link router which they know to work well with their service and this is the only permanent solution to the problem. Otherwise this will keep happening from time to time.

I am not sure what to do because when it works, it will work fine for days on end with no issues. It just starts giving problems when there's a change such as plugging the cable back in the router or any changes from the ISP's end.

I am at my wits' end.

Any ideas or tips would be greatly appreciated.

Thank you very much!
 
Sounds like an ethernet negotiation issue. It's rare, but I've seen it happen. The fix might be to put an unmanaged switch in between their wan and your router's wan. The switch won't do anything except pass the traffic straight through to your router, but since your router and their router are both negotiating with the switch and there's a good chance the switching hardware inside the switch will be different than your router or theirs, it should remove the conflict--that is if it is an ethernet negotiation issue.

Otherwise, you might just have to bite the bullet and get whatever they want. But then if it doesn't work, they better step up and fix it or be sure you can return it in time.
 
Reactions: tenderpops
Jul 13, 2020
2
0
10
0
Thank a lot for your input! I wonder if a simple Ethernet splitter might do the trick, acting as a passive interface between my router and theirs. I'll give that a try.

Thank you, once again!
 

ASK THE COMMUNITY