Question "Can't connect to this network" message for every wireless AP I try

Nov 3, 2019
1
0
10
0
As above, I run into the "Can't connect to this network" message regardless of the wireless AP I select. While trying when my network adapter options page is up, wireless will disable itself about halfway through the connection attempt, only to re-enable itself and provide the aforementioned message. It does this incredibly reliably, and has only developed as an issue earlier today.

So far I've tried :

  • Performing a system restore to a few days ago
  • Uninstalling and reinstalling the wireless driver (tried approx 6 versions with no change, rebooting each time I'd uninstall/reinstall)
  • Ensuring power saving settings are correct (using max performance at the moment)
  • a variety of AP's, including my phones tether option, a free public wi-fi, work's wi-fi, and all sorts. It doesn't appear to be AP unique.
For reference, I have an ASUS FX505DD running Windows 10 Home, x64-bit, version 1809

The wireless card/driver used at the moment is the inbuilt Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC , version : 2024.0.10.102

I would appreciate any suggestions at all, the more I try the more I think it's hardware related but I'm curious what you lovely people think :)

Many thanks in advance.
 
Nov 19, 2019
1
0
10
0
EDIT: My wireless router was the problem. I purchased a new WiFi router and hooked it up as an Access Point only. I created a new, separate SSID and tested downloads on both the Realtek and the TP-Link radios. Internet connection and speed was maintained with no drops.

----------------------

I'm having a somewhat similar issue. I have the Asus TUF505DU-EB74, also with the Realtek 8822ce, running Windows 10 Home, 1909 64-bit.

My problem is that when downloading large files over WiFi, I lose Internet connection, but not the WiFi connection itself. I still have a router-assigned IP address as confirmed through ipconfig.

This happens while I download from Steam, Ubisoft, and via torrents. Internet connectivity over WiFi may eventually return on its own, but normally I have to disconnect completely from WiFi and then reconnect.

If I'm just browsing online or even watching YouTube, I have no issues. I can even remote into the laptop via Teamviewer and run multiple MMO clients, while a couple YouTube videos are playing 1080p, and it's fine. It seems I only lose Internet connectivity (again, not the entire WiFi connection), when the download speed goes above a sustained 10-15 MB/s. At that point, the speed quickly drops to 0 and I can't even load a webpage.

I don't have any problems over a wired connection. On wired, Steam had no problem downloading at like 70 MB/s (I have fiber connection) to either the SSD or HDD, nor did qbitorrent.

Things I've tried:
  • Turning off any power management on the WiFi adapter. No change.
  • Installing latest Realtek 8822ce drivers. No change.
  • Updating BIOS. No change.
  • Turning off IPv6 in adapter settings. No change.
  • Selecting a 'permanent' IP address in the adapter settings. No change.
  • 'Reset' the WiFi SSID and password on the router. No change.
  • 2.4Ghz v 5Ghz network; No change.
  • Run all Windows updates. No change.
I bought a USB 3.0 WiFi dongle: TP-Link AC1300 Archer T3U. With this plugged-in, I disabled the Realtek 8822ce. Guess what? Same problem happens when downloading large files.

So then I thought, OK maybe it's the router. But my dualboot MBP has never had and continues to not have any issues downloading through Steam or whatever, in either OS, on WiFi. I tried downloading the same Steam game to Windows on my MBP and my Asus (obviously not at same time) and the MBP worked like a champ.

To add to the confusion, I was recently at my parents' house and was downloadingon WiFi via the Realtek 8822ce at about 6-7 MB/s and didn't have any issues. I also turned on my phone's hotspot and was able to download smoothly, albeit at only like 1-2 MB/s.

Back at my place, I installed NetLimiter 4.0 and limited download speed to about 7MBps. On one occasion, a game downloaded on the TP-Link with no problem. Idk if that was a fluke or what.

I don't understand how two completely different WiFi adapters, one built-in and one USB, can have the same problem. I saw a suggestion on Amazon (where I bought it) to replace the RealTek with an Intel 9260. It's cheap enough that I'm willing to try it, but is still seems like a far cry, since again two WiFi adapters are already having the same issue.

Anyway, I'll take any suggestions!
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS