Question Cant enable 4K 60hz

shadowkon626

Reputable
Jun 9, 2016
66
0
4,640
3
So i recently bought a Hisense H9F and im trying to enable 4K @ 60hz but I just cant figure it out.

I have an R9 390 with up up date drivers.

Im using a Displayport 1.2 to HDMI 2.0 adapter. Im running an HDMI 2.0 cable from my tv to the adapter which is plugged into the DP 1.2 on my GPU. for whatever reason its locked at 30hz. I am running a 1080p monitor as well. Ive already tried having windows extend the displays instead of mirror and ive already tried only having the tv plugged into my oc as well.

Even if i try to use the AMD custom display settings to set it at 60hz it says my display is not capable.

Every HDMI input on my TV is rated for 4k 60hz.
 

mortemas

Reputable
Feb 11, 2015
683
45
5,190
80
Additionally, I would say that if you are doing 4k/60 with HDR then the HDMI bandwidth only allows this with 4:2:2 Chroma Subsampling. Might want to mess with those settings.

EDIT: Although User MM on Amazon says 4:4:4 works. Follow their instructions here (look for similar settings on your TV).

MM
5.0 out of 5 starsIt works. Simple!
January 10, 2016
Verified Purchase
So far the ONLY option on the market that does 4k 60Hz DP -> HDMI 2.0 conversion.

Confirmed with R9 390 that 3840x2160 60Hz 4:4:4 works.

5.1 Audio pass through works.

TV hardware monitor metadata pass through works.

The only thing I think is not passing through is the hot-plug status, which actually works in my favor. (No more Win10 bug resizing windows with my TV off).

I'm using a Samsung UHD40JU6500. For this particular TV, there are two tricks to make it work:
  1. Label the input source as PC to get 4:4:4.
  2. Turn on UHD Color option for HDMI1, connect to HDMI1, to get 60Hz correctly.
Works with all of my HDMI cables (even the old one from circa. 2008).
 
Last edited:
Reactions: boju

ASK THE COMMUNITY