[SOLVED] Can't enable all ryzen cores

Dec 10, 2018
23
0
10
0
So I currently have a ryzen 5 2600 and it only has 2 cores enabled. I tried to enable all cores by going to system configuration -> boot -> advanced options and for number of processors I put 4 which is the max and restarted my pc. But when I opened up task manager it says 2 cores and 4 logical processors. So I downloaded ryzen master and saw that only 2 cores were enabled so I put it on creator mode and restarted my pc but the changes didn't apply and I still have only 2 cores enabled. Whenever I try to play games such as Fortnite my CPU usage is 85%-100%.

CPU - Ryzen 5 2600

GPU - Radeon RX 580 Armor OC 8GB

Mobo - B450M Gaming Plus

RAM - Crossair Vengeance 2x8gb 3200mhz

PSU - EVGA 600w

OS - Windows 10
 
Go back to the msconfig and uncheck the box "Number of processors" and Reboot.
Check that you have the latest BIOS.
Go back to Ryzen Master.
Click the reset button in the top right corner.
Click OK and reboot.
Check again and see if all cores are enabled.

If you have make changes to the BIOS like selecting a XMP profile or manually setting RAM speed in the BIOS it could cause cores not to show on Windows.
 
Last edited:
Dec 10, 2018
23
0
10
0
Go back to the msconfig and uncheck the box "Number of processors" and Reboot.
Check that you have the latest BIOS.
If you have make changes to the BIOS like selecting a XMP profile or manually setting RAM speed in the BIOS it could cause cores not to show on Windows.
It worked, thanks for the help.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS