Can't enter Bios (GB 880GA-UD3H)


Nov 1, 2011
Hey everyone. Right, so as the title says, I can't enter the BIOS on my motherboard (GB 880GA-UD3H), this is a 2 day old build that I just put together myself from scratch (X4 955 BE, 4GB 1600mhz GSkill, 750W Cooler master and 4850 AMD card); the computer works just fine, I installed Windows 7 without a problem, tried playing games like Bad Company 2 and Elder Scrolls IV without issues or crashes, and so far I haven't had any blue/black screen or any other problem with the build.

However, this board recognizes my RAM as 1333 mhz by default, even though it is 1600mhz, I'm trying to fix it by entering the BIOS but nothing happens when I tap DEL time after time, the weird thing is that I was able to enter QFlash or the Booting set-ups without a problem.

Things I've noticed/done that I think can help:
-Keyboard is PS2 and Mouse is USB.
-Keyboard does indeed transmit the fact that I'm tapping DEL repeatedly to the mobo because for every time I tap DEL I here a small beep from the mobo.
-Tried unplugging the mouse and leaving the KB only.
-After I tap DEL two things can happen:
1. Nothing happens and Windows 7 loads up directly.
2. I'm presented with a screen with something along the lines of "Windows Boot Manager" where I can start up Windows 7 normally or in safe mode, latest safe configuration, etc.
-Like I said before I can enter QFlash(End button), Booting set ups (F12 button) just fine, so keyboard does work.
-I installed the latest drivers using @BIOS (I read somewhere this might be dangerous, but I didn't know that at the time)

Basically that's it, I don't have any clue as to what I could try next. The only thing that I can conclude is that for whatever reason the motherboard, although it receives the DEL instruction, can't bring up the BIOS. Any help will be greatly appreciated, thanks in advance guys.


Mar 24, 2009
I'm having the same exact problem but on a AsRock Extreme7 Gen3 keyboard. I tried repeatedly tapping it... tried tapping it once.. a few times... etc... but to no avail. Not sure what to do! I'm using a USB keyboard too.
You might want to disable the Gigabyte splash screen in BIOS. Then you can see the message "Prepare To Enter Set Up" (or something along those lines) that shows in the bottom-left of the screen when you have successfully pressed "delete" to enter BIOS.