Can't enter BIOS, stuck for sevral minutes then windows starts (Windows 7 home premium)

Dec 7, 2018
2
0
10
0
I used to have a Acer Aspire x1935 but the internal graphic stopped working so i had to buy a new graphic card and some other components and i built a new computer but using the old motherboard.


Now when the computer is running i want to enter the BIOS but it doesn't work. I tried to disconnect all usb-ports but not the keyboard and i connected it to a 2.0 port. When powering the computer i see the ACER logo on the screen(it beeps 2 short beeps) and options to enter the BIOS but i cant get in(every 40 second it beeps one short beep), i tried pressing every key but no success but when i pres the key "PrtScn/SysRq" it sounds a beep sound every time i press it. After the logo has been on the screen for 3-4 min and it has beeped for 3-4 times then windows starts and i can use the computer normally. I used Windows Memory Diagnostic to check the RAM and it said it was working normally. I tried to disconnect DVD-ROM and it still doesn't work, i have tried the keyboard in different ports but still no success and i reset the CSMOS. The Hard drive is connected to SATA 6Gb/s .And i cant find any drivers for the intel graphics

The things i am using:
- MB Kit aLena Intel B75 Acer Logo LF
- Intel i5-3450 CPU (fan connected to cfan1)
- MSI GeForce GT 730 2GB
- 8 gb RAM 1333
- corsair vs550 psu
-3 fans( 2 conected to PSU and one to the moterboard(sfan1)
- (Windows 7 home premium)
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS