[SOLVED] Can't figure out whats causing micro stuttering

wooley

Reputable
Aug 1, 2014
35
1
4,535
0
Old System: https://pcpartpicker.com/list/gTMmcY
New System: https://pcpartpicker.com/list/XLzFD2
This is my hard drive: Hitachi HDS721010CLA630 1TB
But some of the games that I get stuttering in are on my SSD: Sandisk PLUS 240 GB 240GB
Monitor: https://www.amazon.com/gp/product/B075D1B4SV/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1

I upgraded to a much beefier pc, so I'm really unsure what the problem is.
I could only guess that it's something wrong with the stuff I didn't change ( Monitor, HDD, SSD ) Right???

Pretty much what happens is, playing certain games, I notice stuttering.
Mainly I've noticed it in PUBG and Apex Legends, but that's about all I usually play. I definitely have seen the stuttering in other games.
All the time that I've experienced this stuttering it has never become clear to me WHY it is happening.
It usually is very random, but it can get worse after playing for longer periods of time, or maybe when a lot is happening at once in a game.

The bottom line is, my gameplay isn't smooth, where as my friend with a similar setup as me but just worse hardware, gets smoother gameplay than I do.

So there are a few things that I feel like I've noticed that seem to help, but I'm still really unsure if they're true.
  • Turning V-sync on seems to help (but I don't like playing with v-sync because of input lag)
  • Using a friends monitor appeared to help, but since I still noticed some stuttering it wasn't proof that my monitor was the issue
I just want to make sure there's nothing more I can do before going and buying a new monitor or hard drive. A hard drive is cheap and I could use one so I may buy one soon either way.

Please let me know if I can provide more info, I only know so much about PC's and I really want to try and fix this issue.
 
Vsync helps so it appears you're running much higher fps above the monitor's refresh rate?

What's your monitor model and your friends?

When frames aren't synced to the monitor or way above what the monitor can show in a second, can make video playback look jittery.

In NvidiaCP under Vsync options try Fast. If consistently over the refresh rate, enabling Fast can help with input lag.

Alternatively, can try limit fps close to the monitor's refresh rate. Ie; 60Hz / 60fps.

Nvidia Inspector allows to limit fps.
https://www.guru3d.com/files-details/nvidia-profile-inspector-download.html

Under Sync and Refresh set frame limiter to an fps amount and click apply located top right corner of the program.​
Match fps to Monitor's Hz (refresh rate). If it's 60Hz, try 60fps and try play without Vsync on.​
If still jittery, try limit fps to 59 and enable Vsync. The extra frame sort of acts like a phantom buffer which can reduce input lag. It's an unorthodox way of doing things but it can work, I've done it before.​
Ideally, a Gsync monitor would solve these issues immediately but cost is usually a factor.​
Try the suggestions and see how you go.
 
Oh i just seen your monitor.

Have you tried enabling Gsync?

Nvidia has made it possible using Displayport. Enable Freesync in the monitor and enable Gsync in NvidiaCP. Not all monitor's are supported though and results can vary.

 

wooley

Reputable
Aug 1, 2014
35
1
4,535
0
Oh i just seen your monitor.

Have you tried enabling Gsync?

Nvidia has made it possible using Displayport. Enable Freesync in the monitor and enable Gsync in NvidiaCP. Not all monitor's are supported though and results can vary.

Wow, how did I not know this was a thing. This seems to have completely fixed the stuttering! Thank you!
 
Reactions: boju

ASK THE COMMUNITY

TRENDING THREADS