• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Can't find M.2 Nvme SSD in Boot Priority

May 29, 2020
10
0
10
0
Hello everyone,

I just upgraded my system with new M.2 SSD (nvme 250gb Samsung evo plus) and i was able to install windows 10 x64 on it and after installation everything was running smooth. Also while installing windows on M.2 SSD I physically removed all my other storage device from motherboard (sata ssd and hdd). Then i restarted my pc and i got a error blue screen so i did hard restart (from cabinet button) and went into bios to see if my motherboard is detecting the M.2 SSD or not. My board recognizes the M.2 storage in "Onboard device configuration" and also in boot selection menu (the one which comes when you press F8). The strange part is that my boot order is showing only my WD HDD with Windows manager written with it and when i tried to configure boot options from motherboard bios options i can only see my Sata SSD and Sata HDD, i can't find the option to choose M.2 as my primary boot device. I tried everything which i knew and now i have no clues what to do.

Note - I never installed windows on my HDD, i used to have windows on my ssd which i completely formatted after installing OS on M.2 and now it's being used as storage device.

I am able to boot windows and able to use my PC when i choose M.2 from boot selection menu (by pressing F8 on bios) screen.
Please help me because i want to use M.2 as my primary boot as it is super fast and makes my life easy while using my PC. It is so frustrating to always go to bios and select the M.2 from there and then boot. Any help is highly appreciated.




PC Specs -
Mobo -
Asus z97-a
CPU - Intel i7 4790k
Ram - 16gb 1600mz (8x2)
GPU - Zotac RTX 2060 Super
Storage - WD Blue 1TB, Toshiba SSD 128Gb, M.2 nvme 250gb samsung evo plus (2280)
OS - Windows 10 64bit
 
System is installed in legacy mode there.
Samsung Magician has nothing to do with changing boot mode. And changing boot mode is not necessary either.

Make sure these settings in BIOS are configured appropriately
Advanced\PCH Storage Configuration\Sata mode selection - AHCI​
Advanced\Onboard Devices Configuration\PCIE Express Slot and M.2 Bandwidth - M.2 mode​
Boot\Fast Boot - disabled​
Boot\CSM\Launch CSM - Enabled​
Boot\CSM\Boot Devices Control - UEFI and legacy​
Boot\CSM\Boot from Storage Devices - Legacy oprom first​
Boot\CSM\Boot from PCIE Devices - Legacy oprom first​
Boot\CSM\Secure Boot - other OS​

Show screenshots from BIOS
Boot\Boot option priorities​
Boot\Boot override​
 
May 29, 2020
10
0
10
0
System is installed in legacy mode there.
Samsung Magician has nothing to do with changing boot mode. And changing boot mode is not necessary either.

Make sure these settings in BIOS are configured appropriately
Advanced\PCH Storage Configuration\Sata mode selection - AHCI​
Advanced\Onboard Devices Configuration\PCIE Express Slot and M.2 Bandwidth - M.2 mode​
Boot\Fast Boot - disabled​
Boot\CSM\Launch CSM - Enabled​
Boot\CSM\Boot Devices Control - UEFI and legacy​
Boot\CSM\Boot from Storage Devices - Legacy oprom first​
Boot\CSM\Boot from PCIE Devices - Legacy oprom first​
Boot\CSM\Secure Boot - other OS​

Show screenshots from BIOS
Boot\Boot option priorities​
Boot\Boot override​
ok, I will update the bios with these settings. Hope for the best.
 
May 29, 2020
10
0
10
0
System is installed in legacy mode there.
Samsung Magician has nothing to do with changing boot mode. And changing boot mode is not necessary either.

Make sure these settings in BIOS are configured appropriately
Advanced\PCH Storage Configuration\Sata mode selection - AHCI​
Advanced\Onboard Devices Configuration\PCIE Express Slot and M.2 Bandwidth - M.2 mode​
Boot\Fast Boot - disabled​
Boot\CSM\Launch CSM - Enabled​
Boot\CSM\Boot Devices Control - UEFI and legacy​
Boot\CSM\Boot from Storage Devices - Legacy oprom first​
Boot\CSM\Boot from PCIE Devices - Legacy oprom first​
Boot\CSM\Secure Boot - other OS​

Show screenshots from BIOS
Boot\Boot option priorities​
Boot\Boot override​
Here is the image you asked for - View: https://imgur.com/yaXU74T
 

Andyme177

Great
Apr 26, 2020
125
7
95
1
Note
*1 : The PCI Express 2.0 x16 slot shares bandwidth with USB 3.1. The PCI Express slot is default disabled.
*2 : The PCIe x1_1/2 slots share bandwidth with M.2 Socket 3. The M.2 Socket 3 is default disabled.
*3 : These functions will work depending on the CPU installed.

Storage
Intel® Z97 chipset :
1 x SATA Express port, compatible with 2 x SATA 6.0 Gb/s ports
1 x M.2 Socket 3, , with M Key, type 2260/2280 storage devices support (PCIE mode)
4 x SATA 6Gb/s port(s), gray
Support Raid 0, 1, 5, 10
Supports Intel® Smart Response Technology, Intel® Rapid Start Technology, Intel® Smart Connect Technology *3
 
May 29, 2020
10
0
10
0
And Hard Drive BBS priorities screen?
While I was configuring the mobo with your suggested settings I went into Hard Drive BBS priorities and disabled my two hard drives and selected my M.2SSD as option 1 and now everything works fine.

Thanks a lot. I really appreciate the help.
 
May 29, 2020
10
0
10
0
Following are the settings which solved my problem -

Advanced\PCH Storage Configuration\Sata mode selection - AHCI
Advanced\Onboard Devices Configuration\PCIE Express Slot and M.2 Bandwidth - M.2 mode
Boot\Fast Boot - disabled
Boot\CSM\Launch CSM - Enabled
Boot\CSM\Boot Devices Control - UEFI and legacy
Boot\CSM\Boot from Storage Devices - Legacy oprom first
Boot\CSM\Boot from PCIE Devices - Legacy oprom first
Boot\CSM\Secure Boot - other OS
Hardrive BBS - Option 1 = M.2 SSD
Hardrive BBS - Option 2 and 3 = Disabled
 

ASK THE COMMUNITY

TRENDING THREADS