Can't find second HDD

AsRockKid

Reputable
Sep 28, 2015
13
0
4,510
0
I just built a brand-new desktop computer with AsRock H97 Anniversary Board and I5 Intel Processor Quad Core. The system is up and running with Windows 10 Pro as the OS. I plugged in a second HDD SATA and powered it up. The system won't recognize the second drive in power shell, command line, or in disk management. I clicked on 'This PC', and the drive doesn't show up there either. But if I disconnect the working drive and reconnect the second drive that I wish to recognize, it shows up then. Only one drive at a time shows up, but I want to have at least two drives recognized, so I can format one. How do I fix this?
 
Welcome, AsRockKid!

I'd recommend you to try using different SATA cables with the HDDs and maybe even swap the SATA ports on the mobo. Just like Emerald suggested, make sure the SATA ports are enabled in the BIOS and that the HDDs are listed there.
I'd also suggest you to check your motherboard manufacturer's website for any SATA controller updates for your model or attempt resetting BIOS. For the reset you should perform one of the methods listed here: http://www.wikihow.com/Reset-Your-BIOS
Keep in mind, though, that this would get your BIOS settings back to factory defaults, so you'd need to re-configure them.

Hope this helps. Keep us posted with the troubleshooting! :)
SuperSoph_WD
 

AsRockKid

Reputable
Sep 28, 2015
13
0
4,510
0


 

AsRockKid

Reputable
Sep 28, 2015
13
0
4,510
0
I took the following steps based on the information I received last evening from the community. I definitely made some headway! The results are as follows:
1. I plugged in both drives to the SATA connections on the board.
2. I plugged in the power supply.
3. Then I went to ASRock UEFI, BIOS page browser.
4. I clicked on Advanced tab and opened Storage Configuration. All six (6) SATA connectors were listed on the page:
Connection at SATA 0: 500 GB HDD
Connection at SATA 1: Samsung Optical Drive
Connection at SATA 2: 1,000 GB HDD (enabled)
5. When I first came to this page, I had to activate SATA 2. The 1,000 GB HDD appeared in Advanced Storage Configuration page.
6. Windows 10 is installed separately on each HDD.
7. On the same Configuration page, the SATA controllers are enabled. The SATA Mode Selection is set at AHCI. I don’t think that setting can be changed to IDE because the OS has already been loaded on both drives. The IDE is the setting for better maximum compatibility. The AHCI supports new features that improve performance.
Question: Could this setting be part of the issue?
8. I clicked on the Boot tab and selected Hard Drive BBS Priorities. If I set the first Boot Option priority as the 500 GB HDD and then shut down and reboot the PC, the 500 GB HDD comes up as the OS. It works fine.
9. If I reboot the PC and go into BIOS and make the 1,000 GB HDD as the first Boot Option priority and then shut down and reboot the PC, the 1,000 GB HDD comes up as the OS. This also works fine.
10. The underlying problem is still that when both drives are plugged in and I go to Disk Management and This PC, only the drive that is booted up and the optical drive are recognized. That also holds true when I go to Power Shell and Command Line.
11. My goal is still to have both drives recognized in Disk Management so I have the option to format the second drive.
Thanks to your advice, I’m a lot closer to solving the problem than I was last evening!
12. In the next 5-10 days I’m going to do a brand-new build with the same parts as this machine. I’ll make it a priority to set the SATA Mode Selection to IDE before I load the OS.
Question: Does it make a difference in recognizing the second drive with Windows 10 whether the OS is Windows 10 Professional or Windows 10 Home?
AsRockKid 9-29-15
 
Hey there again, AsRockKid!

Indeed, the placement of the HDDs could be part of the issue, especially if one of the SATA ports was faulty. However, I don't think that the OS itself could influence this.
I do suspect a faulty cable and I'm not sure if you've tried using a different SATA cable already. Once you've configured your brand new rig, I'd recommend you to swap the SATA cables that come with the mobo and hopefully it would get both of your HDDs recognized by your current system.

Best of luck! Keep us posted though! :)
SuperSoph_WD
 

ASK THE COMMUNITY