Can't get into BIOS, "Can't find any devices"


May 22, 2010
First off, I have only built two other systems before so consider me a big noob. =)

I decided to upgrade my computer over christmas with with a new Motherboard and processor:
-Intel Core i7-2600k
-ASUS P8Z68-M Motherboard

I installed Windows 7 sucessfully and all was well but everytime I booted up it would show the splash screen and then say
"Can't find any Devices", it's not a big deal because it reboots itself and then finds my SSD and boots Windows. At first I figured it was because the DVD drive was first in the boot order but after I moved it down so that the SSD was first the problem continued. I decided to ignore for now and troubleshoot later. I think this is a board wide issue because it also takes 5 or 6 extra seconds to find the keyboard. But any help on this would be appreciated =)

I also have a second problem(YAY!) I want to load ubuntu so that I can work with android a little easier, I have a third hard drive for this. The hard drive is formatted and everything but that is beside the point. I knew that Flash drives were on the lowest level of the boot order so I tried to move it up to save me some time but when I tried to boot into the BIOS settings I realized I did not have an option to do so.

When I turn on my machine it takes a few seconds for my monitor to recognize the signal but I could still catch the BIOS before it booted into windows. Since it has to restart to recognize my SSD I could catch the BIOS setting the second time around but now there is so more option to do so. It goes to a screen that lists all of the hardware I have connected. On my old motherboard this is where I pressed delete to get into the setting but there is no option here. I tried pressing "delete" F1, F12 but it just boots right into windows. I tried holding the Pause button on my keyboard until my monitor could connect but since my keyboard isn't recognized for few seconds It doesn't matter anyway since there is no option to go to the settings. I tried a wireless and wired keyboard but they both take too long and I tried a few different monitors but they are all too slow.
I'm sure it is user error but I can't think of any other ways to troubleshoot it.

Thanks in advance for anyhelp and HAPPY NEW YEAR!


Jun 17, 2010

Not for nothing but I don't think you should ignore the fact that your computer is rebooting by itself. Thats a problem. It would be a good idea to add all your system periferals in your public profile so we know what hardware were working with. IE. make,model and size of SSD, HDD Video card, keyboard etc. If you add that info to your public profile it will always display when you post a question.

It sounds to me that you haven't added to many programs yet so why don't you try re-installing Windows again. If you plan on having a Hard disk storage drive re-install Windows to the SSD without the storage drive attached. Make sure the motherboard is booting into AHCI mode. Many SSD's require a firmware update as well, I would sort all that out first. After Windows is running correctly and your machine boots properly update all the drivers for your hardware. Its best to go to the manufactures website to do this rather than using the supplied disks (usually older), then you can add Umbutu. Do you realize you can partition a drive and load Umbutu to the partition.