Question Cant get my gpu to seat all the way

Oct 23, 2020
6
0
10
0
I’ve been out of the pc game for 5 years now an just finished my first legit build. From the Ground up and my gpu isn’t showing up in device management or display or anything but it’s getting power. It won’t go down any further and I don’t wanna break my mobo lol. It clicked in but I feel the side towards the ports isn’t seating an maybe the bracket you screw down to hold the gpu in place needs to be bent up or something?????? . Idk any help or ideas would be appreciated.
 
Oct 23, 2020
6
0
10
0
I’ve been out of the pc game for 5 years now an just finished my first legit build. From the Ground up and my gpu isn’t showing up in device management or display or anything but it’s getting power. It won’t go down any further and I don’t wanna break my mobo lol. It clicked in but I feel the side towards the ports isn’t seating an maybe the bracket you screw down to hold the gpu in place needs to be bent up or something?????? . Idk any help or ideas would be appreciated.
I got the cougar
Remove the GPU and check that there's nothing lodged in the pcie slot or that there's no damage to the GPU pcie connector.

PC Specs?
It’s a budget build so I went AMD
My specs:
gigabyte 550m ds3h mobo
Ryzen 5 3600x cpu
32gb 3200 G skill trident z ram
Asrock 5700xt taichi 8gb gpu
850w gold cert psu
1tb ssdSamsung evo
1tb sshd
 
Oct 23, 2020
6
0
10
0
So I removed it checked everything all was good I put back in an now no power at all..... to anything all I did was remov gpu and put it back in... : ( I powered down turned psu off an now just nothing.
 
Oct 23, 2020
6
0
10
0
Sry had to get some sleep before work. But I got it all to boot back up and I think I just need to manually download gpu drivers an then maybe it will show up on devices. My display is going through the gpu an lights are on on gpu and my mobo doesn’t have an integrated graphics so I’d assume it is working just not showing up in devices. As soon as I get home from work I’ll download drivers an see if it fixes it.
 

SteveRX4

Notable
BANNED
Sep 29, 2020
1,477
135
890
20
Looks nice. It's good to see that you worked it out. I think it helps to have someone as a sounding board on stuff like this.
You should put [SOLVED] on the LH of the thread heading so that a Mod will close it.
I hope I've been of some help.
 

ASK THE COMMUNITY

TRENDING THREADS