Can't get new 144HZ Monitor and secondary Monitor to work at the same time.

kasol kay

Honorable
Mar 22, 2013
232
0
10,760
36
Previously I had two 60HZ Monitors both connected via Mini DP, one Mini DP to full sized DP and one Mini DP to HDMI.
After upgrading one Monitor to 144HZ the other won't detect when plugged in, as soon the 144HZ Monitor is unplugged the 60HZ Monitor is detected and Displays normally.
I've tried plugging the HDMI Cable directly into the GPU and messing with Drivers but no luck there.
I would buy and try different Adapters e.g DVI to VGA/HDMI but I'm curious if this a Hardware limitation and I'm wasting my time trying.

My GPU is an R9 280X so not exactly cutting edge, and the Displays outputs are DP and 2X HDMI on the 144HZ/ and VGA/HDMI on the secondary.

Any advice is appreciated
 

kasol kay

Honorable
Mar 22, 2013
232
0
10,760
36
The 144HZ Monitor is a ViewSonic XG2402 and the second is just a generic AOC 60HZ TN Panel.
The Card model is the XFX DoubleD R9 280X.
Tried putting the 144HZ in 60HZ but didn't seem to do anything.

Also the second Monitor has a DVI, I should've checked properly although I'm not sure this matters.
 
seems strange.
I understand that you have tried to use (DP->DP + HDMI->HDMI) and (DP-> DP + DP->HDMI) ports on the card to connect the monitors, is it correct ?
what happens if you connect the 60Hz monitor first and then the 144Hz ?
I'd try to use DVI to VGA cable for the 60Hz monitor - the port that supports it is on the same row as the DP and HDMI.
 

kasol kay

Honorable
Mar 22, 2013
232
0
10,760
36
Would you recommend I go buy a standard DVI Cable or an Adapter? Also my GPU has two slightly different looking DVI Ports.
And thanks for your help in General
 

kasol kay

Honorable
Mar 22, 2013
232
0
10,760
36


Alright, appreciated I'll go pick up a DVI Cable.
 

kasol kay

Honorable
Mar 22, 2013
232
0
10,760
36


If I connect the 60HZ Panel first then connect 144HZ Panel the 144HZ Panel takes priority and the 60HZ Panel loses Signal.
 

Karadjgne

Titan
Herald
And you are sure you have enabled multi-monitor in windows and bios and set your desktop to extended in the video settings? If not, default is for single monitor only,so the higher ranked connection takes priority.
 

kasol kay

Honorable
Mar 22, 2013
232
0
10,760
36
I haven't checked the Bios, but I did have 2X 60HZ Monitors working, but 144HZ Monitor only works alone even when set to 60HZ.
I would set it to extended but since it doesn't detect the other Monitor I can't.
The AMD settings just open up the Windows Display settings when you click to arrange Displays.

 

ASK THE COMMUNITY

TRENDING THREADS