Can't install most of stuff, permission issues windows 7

Jan 28, 2019
1
0
10
0
Here's my problem.
Maybe a week ago, I was uninstalling some of programs from my PC. I can't remember if then the PC froze or if I was prompted to do a restart, either way, the pc restarted and the CHECKDSK has started from the boot. Since I haven't done it in a while I let it run, then after it completed it started to do the "replacing invalid security ID with default security ID". It was the first time had experience with it, so I let it run since I thought it was repairing something. After a few hours, it stopped and the PC restarted. Then, the pc only booted to a black screen with only a movable mouse pointer on the screen. I googled what the possible cause could be and figured out that it could be file persmission access. So I entered the Windows Repair CMD, typed the full access command and I restarted, and booted succesfully. Then I went into CMD run the "SFC" and it stated that there are a few problems it could not resolve. I thought that there might be some malwares on the pc or bad registry inputs. So I went and downloaded malwarebytes but when I wanted to install it I couldn't. I simply did not have enoug permissions to install it. It installed partly. So i wanted to delete the partly installed files ( there was a folder with malwarebytes files in program files), but when i wanted to open the folder it said that i dont have permission to open the folder. I got the same message when i wanted to delete it. I tried giving admin rights with the properties-security tab, but it wouldn't let me, it would pop up an error after a few files. Then i wanted to install something else, same error. And most of the stuff that i want to install gets rejected in the middle of the installation. I really don't know what to do anymore. This is just a roughly explanation of my problem. I want to resolve this problem without reinstalling windows, so i thought that this is the best place to seek for help. Any help is welcome. Thank you :)
 

ASK THE COMMUNITY

TRENDING THREADS