[SOLVED] Cant install windows 10 from USB drive on MSI B450m pro-vdh?? (Very, very weird)

BlueGhost82

Distinguished
Aug 26, 2013
43
3
18,545
1
Hello I am litterally pulling my hair out trying to figure this out.

First off, yes, I used the media installation tool from the official microsoft website
Second off, yes, I can hook this usb drive up to any system and it will work to install windows 10.

At first, I was able to boot off of it. But when installing windows to the Samsung sata SSD it said "Windows cannot be installed to this disk, this computers hardware may not support booting to this disk. Ensure the disks controller is enabled in the bios"

I thought that was weird as I have never seen that before. So I booted into the bios and reset all bios settings to default and made sure boot mode was set to UEFI + Legacy. Now the installation media does not detect at all.

I ran a check disk on the SSD to make sure it was good and it is, crystal disk mark also says it is good no issues. Ran a memory test and one of the 8GB memory chips was bad apparently so I removed it and ran another memtest which the one 8gb chip tested good.

I cant find ANY settings in this motherboard related to CSM. I see ACHI which it is enabled and the only other option is raid. I was able to figure out how to enable/disable secure boot by changing the option to custom to get the bios out of setup mode and into user mode.

I am litterally at my whits end with this thing never seen anything like it.
Any help would be sincerely appreciated. Thank you.
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,459
5,086
166,290
10,419
Are there any partitions on the drive?
Try deleting all the partitions and click next in custom install
follow this guide: https://forums.tomshardware.com/faq/how-to-do-a-clean-installation-of-windows-10.3170366/

a few other suggestions here - https://superuser.com/questions/1074592/computers-hardware-may-not-support-booting-to-this-disk-when-trying-to-instal

have you got latest BIOS for motherboard?

I cant find ANY settings in this motherboard related to CSM.
Compatability Support Module (CSM) is also known as Legacy. That might help you find it.

The only spot it really matters is on the boot tab
Boot Mode Select [LEGACY+UEFI]
Sets the system boot mode from legacy or UEFI architecture depending on OS installation requirement. This item will become un-selectable and will be configured automatically by BIOS when Windows 10 WHQL Support is enabled.

[UEFI] Enables UEFI BIOS boot mode support only.
[LEGACY+UEFI] Enables both Legacy BIOS boot mode and UEFI BIOS boot mode.

B450 board manuals lack info about BIOS so this one might help more - https://download.msi.com/archive/mnu_exe/mb/E7B79v2.1-GSE-LITE.pdf
eset all bios settings to default and made sure boot mode was set to UEFI + Legacy. Now the installation media does not detect at all.
Install media should work if you set it to UEFI only as the installer can run on either forrmat
 
Last edited:

Colif

Win 11 Master
Moderator
Jun 12, 2015
60,459
5,086
166,290
10,419
Are there any partitions on the drive?
Try deleting all the partitions and click next in custom install
follow this guide: https://forums.tomshardware.com/faq/how-to-do-a-clean-installation-of-windows-10.3170366/

a few other suggestions here - https://superuser.com/questions/1074592/computers-hardware-may-not-support-booting-to-this-disk-when-trying-to-instal

have you got latest BIOS for motherboard?

I cant find ANY settings in this motherboard related to CSM.
Compatability Support Module (CSM) is also known as Legacy. That might help you find it.

The only spot it really matters is on the boot tab
Boot Mode Select [LEGACY+UEFI]
Sets the system boot mode from legacy or UEFI architecture depending on OS installation requirement. This item will become un-selectable and will be configured automatically by BIOS when Windows 10 WHQL Support is enabled.

[UEFI] Enables UEFI BIOS boot mode support only.
[LEGACY+UEFI] Enables both Legacy BIOS boot mode and UEFI BIOS boot mode.

B450 board manuals lack info about BIOS so this one might help more - https://download.msi.com/archive/mnu_exe/mb/E7B79v2.1-GSE-LITE.pdf
eset all bios settings to default and made sure boot mode was set to UEFI + Legacy. Now the installation media does not detect at all.
Install media should work if you set it to UEFI only as the installer can run on either forrmat
 
Last edited:

BlueGhost82

Distinguished
Aug 26, 2013
43
3
18,545
1
Are there any partitions on the drive?
Try deleting all the partitions and click next in custom install
follow this guide: https://forums.tomshardware.com/faq/how-to-do-a-clean-installation-of-windows-10.3170366/

a few other suggestions here - https://superuser.com/questions/1074592/computers-hardware-may-not-support-booting-to-this-disk-when-trying-to-instal

have you got latest BIOS for motherboard?


Compatability Support Module (CSM) is also known as Legacy. That might help you find it.

The only spot it really matters is on the boot tab
Boot Mode Select [LEGACY+UEFI]
Sets the system boot mode from legacy or UEFI architecture depending on OS installation requirement. This item will become un-selectable and will be configured automatically by BIOS when Windows 10 WHQL Support is enabled.

[UEFI] Enables UEFI BIOS boot mode support only.
[LEGACY+UEFI] Enables both Legacy BIOS boot mode and UEFI BIOS boot mode.

B450 board manuals lack info about BIOS so this one might help more - https://download.msi.com/archive/mnu_exe/mb/E7B79v2.1-GSE-LITE.pdf


Install media should work if you set it to UEFI only as the installer can run on either forrmat
Well I feel like a dummy. So actually just updating the bios to the latest version fixed everything. The bios was drastically changed with from the older version and I was immediately able to boot off of installation media and install windows with no issues. Sorry about the rant. IT may not be for me after all haha. Patience and thoroughness really is key. I appreciate the help.
 
Reactions: Colif

ASK THE COMMUNITY

TRENDING THREADS