Can't install windows on corsair P128 ssd


Jul 22, 2009
I recently purchased the P128 and put it in my gateway T-1628 but for some reason; after the gateway logo screen disappears, all I see is the black screen with blinking cursor on the top left screen.

I went to bios and it was able to detects the SDD but after I exit, it wont let me boot the recovery discs or the windows 7 disc. It wont let you boot anything. So I took and plugged it into my desktop, formatted it as primary and plugged it back it into the gateway but same old.

I flashed the bios with the latest update but it doesn't solves anything. The gateway bios for this laptop is very basic, it doesn't have setting for hard drive.

Anyone have any ideas? Am I purchased the defected ssd?


It's more probable that your laptop's motherboard can't support the SSD, based on what you said about it being detected on your desktop.

Another probable cause is that the motherboard is faulty; there could be issues with the port you plugged the SSD into. Are you able to remove the disk you currently use on your laptop, and plug in only the SSD?


I am having the same issue - I was going to install Windows 7 OS on here and ditch my Vista. Windows 7 won't recognize my Corsair 128 GB SSD drive. I boot into Vista and I can see it, format, assign a drive letter and read/write from it.

Boot off the Windows 7 DVD, it sees my other drives but not this one. There are no drivers for this, so what do I do from here? I guess I could install Vista clean on the SSD and upgrade to W7 - but I'd rather get a clean tight W7 install if I could...

I would LOVE some ideas here, as I would love to be able to install W7 on this SSD and watch it scream!!!


Aug 21, 2009
Same issue here: I see the Corsair SSD in BIOS and in the Device Manager, but I can't see it in Win Explorer.

Did you every find a solution to this problem?
Do you have an external enclosure so that you can connect the SSD to your laptop.
Install crystal Disk info on your laptop HDD (ie vista/win 7) and see if it sees your SSD. Also if you see it, verify you have latest firmware installed.

Just installed a patriot Torqe 128 in my Toshiba 305 last night - went smoothly. But before install, I install cytal info on Win 7 HDD. I stuck the SSD in a esata/usb enclosure and verified that the bios could see it and that it had the latest firmware. If the Corsair is based on the new samsung controller - Not sure if there is a flasher out yet and if there is a newer firmware out. Noted that there has been several questions on When Samsung will issur a new firmware updater.


Oct 23, 2009
I have SOLVED this problem.

I had an identical problem where the BIOS could see my SSD (Kingston v-series 128GB), and when I booted into windows I could see it and format it and assign a drive letter. But Windows 7 install COULD NOT see the SSD, and Acronis True Image could not see the SSD to clone my old system disk to it.

Very frustrating and it took me 2 days to work it out. I tried EVERYTHING and didn't really find an answer on ANY forum. But the solution was simple...

Physically remove connections to ALL disks on your computer EXCEPT your SSD so it's the only disk connected. Then Windows install WILL see the SSD and you can install Windows 7 to it (and I assume Vista).

If you are trying to clone your system disk to the SSD like I was, I know it's kind of a long way to go about it, but I had to install Windows to the SSD with the above method, and then use Acronis True Image to clone my system disk to my SSD. After Windows is installed on the SSD, Acronis will see the SSD.

BTW... my system is approximately twice as fast. It boots in half the time and apps open up very quick. I'm totally happy.

Hope this helps!


Feb 19, 2007

Same thing happened to me, it turned out to be a setting in the Bios.

"Ok, I poked around in the BIOS, and when I enabled an option called "uefi boot" it allowed me to boot from the windows 7 disk and install on to my SSD, even when my other hard drive wasn't in the machine.

I dunno why I needed to do that, but if anyone has the same problem, that fixes it. "


Jul 10, 2009
The uefi is a new thing that is supposed to take the place of BIOS.
Maybe Corsair jumped the gun, because the change is supposed to start taking place in 2011. So maybe the SSD just has a hard time with certain BIOS, but UEFI is supposed to be superior, so maybe the solution is everyone could run it with UEFI enabled, but not all could run it the traditional way. Such as every square is a rectangle, but not every rectangle is a square. Just my two cents.

Article about UEFI: