Question Can't install Windows on my M.2 SSD. Tried for several hours and got nothing.

Jan 13, 2022
4
0
10
0
I bought new pc parts excluding storage and GPU and can't install Windows on my old M.2. Specs first then the problem.



New parts:

MB: MSI MAG B550 Tomahawk

CPU: AMD Ryzen 7 5800X

RAM: Corsair 8gb x4 Vengeance LPX, DDR4 3600MHz (changed to 3200MHZ due to performance problems on testing)

PSU: Seasonic 750W FOCUS GX-750



Old Parts installed to new PC:

GPU: Nvidia GeForce GTX 2060 Super

M.2 SSD: Intel HBRPEKNX0202AH (500GB)



I bought the parts with installation so everything left for me was to install storage and GPU, so the company I bought the PC from, did the testing on RAM.

The problem is that Windows installation tool wouldn't show the SSD. Me and my friend tried for several hours. We launched with secure boot on, we launched with both UEFI and CSM and nothing worked. BIOS shows the SSD everywhere excluding boot options.

After trying to solve the problem on BIOS we tried to get it work through CMD on the Windows installation tool. We got it to show up, but even after cleaning the SSD, it would show up with 27GB despite being 500GB SSD and wouldn't let it install.

Is the Intel SSD just not compatible with AMD motherboard or is there something left to try? Thanks in advance!
 

dwd999

Honorable
Feb 24, 2016
722
107
11,240
59
The windows installer is very fussy about drives; it prefers drives which contain only a gpt partition identifier and where all of the space is unallocated. Also if there is more than one drive, they all need to be gpt and unallocated, otherwise if any of the drives have windows files they will mess up the booting process. One drive at a time is always best.

It also helps to think outside of the windows box. I recommend booting up with a usb containing either gparted or a linux distro containing gparted. I use gparted to set the gpt partition identifier and to make sure that all of the space on the drive is unallocated. I did this yesterday when I put new larger ssds in one of my builds and everything worked perfectly.

https://gparted.org/download.php

Note that you have to use the version labelled amd64 for compatibility with the windows secure boot requirement.
 

n3mes1s

Commendable
Sep 13, 2019
6
0
1,510
0
You dont get it. That is completely useless, because the main problem is that the SSD partition is only showing up in bios, but NOT everywhere else, so programs like GPARTED will be useless. Im having a similar issue, cant get my M2 drive to show up not even in bios, and this after almost TWO YEARS of using it without problems. Only when i completely shut down the pc, and i wait, and i turn it on again, the bios recognizes the M2. But if i save changes in the bios and restart, the bios does not see the M2 anymore. And of course, its invisible as well for any OS.

Without another pc to try the M2 stick, i need to assume the stick is damaged or it just doesnt work anymore.

Ive read in a lot of forums that M2 drives are unreliable, and they have a lot of problems in many Mobos. In my case im not going to use an M2 ever again lol. You would say that in 2022, things like these cant happen, and there are failsafes, or manufactures will grant you a correct working piece of hardware, but its all marketing and a stupid competition and technology has advanced completely nothing since a decade ago. They still scam people to buy expensive pieces of hardware they are experts at that, but thats all it is.
 

ASK THE COMMUNITY