Question Cant make uefi Win 10 install on nvme

Mar 20, 2022
7
0
10
0
hi, i just tried to install a windows 10 copy with rufus on an Nvme ssd, once the instalation completed my mobo wont detect my bootable Nvme, i needed to unable CSM but when i do i get a Rufus message that tells me to "Boot in uefi mode only"

This is how i installed windows
1- The M.2 was the only drive pluged in.
2 - Got into the BIOS, CSM was disabled.
3 - set secure boot to "other OS", not "Windows UEFI".
4 - Click on key management and cleared secure boot keys.
5 - Inserted a USB memory stick with a UEFI bootable iso of Windows 10 on it.
6 - Pressed F10 to save, exit and reboot.
7 - Windows 10 start installing to my Nvme drive.
8 - When the PC rebooted hit F2 got back into the BIOS, There was no Nvme on boot devices
9 - Clicked on secure boot again but now set it to "WIndows UEFI mode"
10 - Clicked on key management and installed default secure boot keys.
11 - Pressed F10 to save and exit then i got "No boot device detected, press any key to reboot ect"
Here is my system
-Asus tuf gaming b460m-plus bios Version 1003
-Core i5 10400f
-Gtx 1660
-Adata xpg sx6000 lite nvme 256gb converted in GPT
-16gb ram

As of right now i am using my old hdd whitch is partitioned in MBR with CSM enabled, olso i tried to install win 11 on that ssd with another mobo before & i see 3 partition, i formated that Efi partition & the partition that i installed win 10,but i cant format that last partition!
 
Last edited:
Your system probably sees the USB stick as the boot drive and doesn't install any boot files to the nvme.
You can either boot into windows installation again and try boot repair, or check your bios settings and make sure that the usb is not in the boot devices list, boot from the usb by pressing whatever key your mobo has for boot menu at startup and do a new install again.
 

dwd999

Honorable
I am using my old hdd which is partitioned in MBR with CSM enabled, olso i tried to install win 11 on that ssd with another mobo before & I see 3 partition, I formatted that Efi partition & the partition that i installed win 10,but i cant format that last partition!
Well for starters, you could try using a real partitioning tool like Gparted to remove all of the old partitions so that the hdd space is totally unallocated. While you're there, use the Gparted menu to install a new GPT partition table on the hdd. Then at least the hdd will be properly prepared for a Windows UEFI install. It also sounds like you're messing up the Rufus installation of the installer ISO file onto the usb but I can't figure out what you're doing so I don't know how you're messing that up. Its pretty simple, you start Rufus, select the Windows installer ISO file and click the Start button. When its done you simple reboot the usb and the installer starts.
 
Mar 20, 2022
7
0
10
0
Hi & thanks for your help guys
Your system probably sees the USB stick as the boot drive and doesn't install any boot files to the nvme.
i cant do it, if i disable boot option, i wont be able to see the USB drive
Why Rufus and not the MCT from MS?
I am using my old hdd,Clarify, please.
i removed my HDD when instaling, when install failed i put it back in
i just downloaded MCT, i will make a bootable device with MCT tomorrow.
It also sounds like you're messing up the Rufus installation of the installer ISO file onto the usb but I can't figure out what you're doing so I don't know how you're messing that up. Its pretty simple, you start Rufus, select the Windows installer ISO file and click the Start button. When its done you simple reboot the usb and the installer starts.
I did use rufus as usual, selected the iso file, gpt (uefi-non CSM) & then installed
Olso guys when i went to bios before the instalation i saw 2 USB Uefi partitions, i selected the 1 st one to install

maybe some clues on this pics
https://ibb.co/H7ch4X6
https://ibb.co/hg4Lgm2
 
Last edited:
Mar 20, 2022
7
0
10
0
UPDATE:
Made a bootable usb with windows media & troubleshoot the installation, both failed.

Cleaned all the ssd patitions and re installed olso failed

I can still use the Nvme as a storage but only in csm mode ON other wise it wont show up in full Uefi.
Even tho i cleared the managment key before the installation, i think some drivers are missing.

il update the bios to the latest version and move the nvme to M. 2 _1 slot and try, thats my last move am out of ideas 😭

One last question, can i create a bootable MBR Nvme ?
 
Last edited:
UPDATE:
Made a bootable usb with windows media & troubleshoot the installation, both failed.

Cleaned all the ssd patitions and re installed olso failed

I can still use the Nvme as a storage but only in csm mode ON other wise it wont show up in full Uefi.
Even tho i cleared the managment key before the installation, i think some drivers are missing.

il update the bios to the latest version and move the nvme to M. 2 _1 slot and try, thats my last move am out of ideas 😭

One last question, can i create a bootable MBR Nvme ?
If it's a driver issue go to your mobo website and search for Preinstall driver or any driver that says something about loading from usb, (should be under sata/raid or chipset) then during windows installation choose custom and when it shows you the drives click on the load driver icon and load the drivers from the usb, needs to be unzipped beforehand.
 
Mar 20, 2022
7
0
10
0
dont change secure boot during windows installation process
set secure boot as windows OS
boot from windows installation media
install windows
reboot
dont touch bios, let it boot on its own
Just did what you asked, & i olso tryed to disable Tpm & install same thing, i olso switched to the other M.2 port same result
Once i install windows i have t oenabble CSM to have a bootable option on the list but it wont work cauz i installed windows in Gpt, its like once i install windows on my ssd it converts to MBR even thos when i cheked my partion was still in *Gpt
 
Mar 20, 2022
7
0
10
0
what happens once you preinstall windows from usb media, after reboot what happens without you pressing anything?
Goes back to instalation menu & if i remove the ubs once the instalation is complet i get to the bios where i cant see a bootable ssd, but when i plugged my hdd back & connected to windows i could see that there are a windows instalation on my ssd & a file called boot with multiple files on it but i dont know those things =(

When i ennable CSM i can boot on my ssd but i get windows troubleshoot menu Ennable to keep the boot to desktop

1 more thing, before i start the installation i had to command CMD to create a partition on my ssd cauz windows required me that & when i finished & rebooted my ssd was in MBR mode, i had to convert it to GPT & then started the instalation
 
Last edited:

ASK THE COMMUNITY