Question Can't overclock RAM in dual channel

Oct 2, 2022
1
0
10
0
Hi everyone.

My PC specs are :
  • MB : Aorus B450 elite v1
  • CPU : AMD Ryzen 5 2600 OC 3.95ghz at 1.35v
  • GPU : Palit GTX 1060 6gb
  • PS : Enermax Revobron 600w
  • RAM : HyperX Savage 2x8 kit DDR4-3000 15-17-17-39 1.35v (2 and 4 slots)
My previous HyperX Fury ddr4 2400 2x4 kit ram could get up to 2933mhz (MB limit) with no issues, except the really high timings it required to boot. But my new RAM just won't go past 2733 mhz (even with CL25 and 1.4v). When I put only one stick at a time, it works perfectly fine at 2933. They even get 2933 when put into slots 1 and 2, but it's a single channel so this isn't a solution.

I've tried :
  • Every possible slot configuration
  • Updating and downgrading BIOS
  • Resetting BIOS
  • Overclocking the CPU to 4.1Ghz
  • Increasing SOC voltage to 1.1v
  • Setting really high timings and voltage
  • Overclocking one stick, then another, but when I put them both already set to 2800mhz with xmp-3000mhz timings, it looks like PC is booting. It doesn't turn off and doesn't bootloop for 3 times. It is just stuck at VGA light and monitor doesn't even turn on.
  • Sometimes it helps to loosen cpu cooler screws, but I did not tighten them hard when accembling my PC.
I've read many threads, tried every possible solution, and nothing helps. I would be so grateful, if somebody helped me with this overclocking paradox.
 

ASK THE COMMUNITY

TRENDING THREADS